powered by Jive Software

Home not found ?!

I tried to install the latest release of jive messenger on a fedora core 4.

and after the installation was completed, i restarted the server and i got this error:

Jive Messenger Setup

Error: Can not proceed with Jive Messenger Setup.

Your current installation fails to meet minimum Jive Messenger requirements - please see the checklist below:

(ok)At least JDK 1.5

(ok)Servlet 2.3 Support

(ok)JSP 1.2 Support

(ok)Jive Messenger Classes

(!!!)Home not found. Define system property “messengerHome” or create and add the messenger_init.xml file to the classpath

Please read the installation documentation and try setting up your environment again. After making changes, restart your appserver and load this page again. /i

when i installed the server I entered as the host, my internet IP address, which is static.

i would appreciate any help.

regards.

I think what it’'s asking for is the directory where you installed Messenger. /opt/jive/messenger for example.

Noah

yeah … I got that, but where would I insert that, or what file should I modify?

try:

MESSENGER_HOME=/opt/some/path messenger.sh[/code]

yeah… but… once again… where would I write that (in what file) ???

sorry if I seem to be totaly out of any ideas, but that’'s the truth also… i have no idea what to do… i tried everything

First, does that work on the command line? Make sure that works, then look at /etc/init.d/jive-messengerd on your machine. That’'s the best place to store this type of configuration.

Noah

no… it doesn’‘t;t work… either way… it just doesn’‘t work… but the funny part is that i can use the IM server, so. it’‘s running, but i can’'t use the administration panel.

It’'s a permissions problem. I had this exact same issue, after doing an upgrade from 2.2.0 to 2.2.1.

If your setup is running as user “jive”, like it would be set to after installing from the RPM, run:

chown -R jive:jive /opt/jive_messenger

This is fixed up by running the redhat-postinstall.sh script on a new installation, but most of that script is unnecessary for an upgrade. Just fixing up the ownership should sort you out.

indeed it works… thnx alot.