How do i increase java memory in latest version


I encountered when i try to modify or added something for java memory

here is the code:

-Xms512m -Xmx1024m

then when i run the openfire the java memory still 64mb but earliest version its works fine…

is anybody encountered like this.

please help.


This is like saying the sky is blue why won’t my plane fly.

What OS is the server running on?

Is it running as a service?

If on linux what is the full launch thread.


thanks for your reply

Well i solve my problem now,

here is my procedure:

  1. I backup my database

  2. remove my old version of openfire

  3. reboot my pc

  4. install the latest version

  • Before i do that i need to modify the file of

and I add this:

OPENFIRE_OPTS="-Xms512m -Xmx1024m ${OPENFIRE_OPTS} -DopenfireHome=${OPENFIRE_HOME}"

and save it.

then its time to install thru webbased installation

example: http://localhost:9090

i followed the instruction on the openfire website.

to take effect of my java memory i have to see or wait this on my server monitor to appear.

something like this “database update succesfully”

coz if not based on my observation still 64mb it wont effect if your not see that.

but last night i tried so many times then suddenly im lucky:) then now everythings works fine.

my java memory got now 1024mb

I used Linux Fedora8 and Im not using GUI, it is a Terminal mode.

Since i fixed my problem there another i noticed during i exploring the openfire…i will post new thread…

its about Email Function.

Thanks everyone and regards to all