powered by Jive Software

How Do I Increase Java Memory?

Hie.

Could anyone tell me how I can icrease Java Memory. Now Java’s memory is 64 MB and I would like to increase to 128 MB at least.

I’m using Wildfire 3.1.5 and it is no longer workings as good as it has been doing some months ago.

See the errors bellow:

2008.03.06 14:36:43 [org.jivesoftware.wildfire.net.SocketReadingMode.negotiateTLS(SocketReadingMode .java:75)

at org.jivesoftware.wildfire.net.TLSStreamHandler.doHandshake(TLSStreamHandler.jav a:294)

at org.jivesoftware.wildfire.net.TLSStreamHandler.start(TLSStreamHandler.java:250)

at org.jivesoftware.wildfire.net.SocketConnection.startTLS(SocketConnection.java:1 73)

at org.jivesoftware.wildfire.net.SocketReadingMode.negotiateTLS(SocketReadingMode. java:72)

at org.jivesoftware.wildfire.net.BlockingReadingMode.readStream(BlockingReadingMod e.java:126)

at org.jivesoftware.wildfire.net.BlockingReadingMode.run(BlockingReadingMode.java: 62)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:123)

2008.03.06 17:12:19 [org.jivesoftware.database.ConnectionPool.<init>(ConnectionPool.java:108)

] Failed to create new connections on startup. Attempt 0 of 3

I would aprettiate so much if anyone could help me.

What OS is the server running on? Is there a reason you are not updating your server?

Hie Sir.

the server is running Win XP SP2. There is no specific reason. I still want to test the latest version.

Custom Parameters

Advanced users may wish to pass in parameters to the Java virtual machine (VM) to customize the runtime environment of Openfire. You can do this by creating vmoptions files in the bin/ directory of your Openfire installation. For the Windows service, you’d create a new text file called openfire-service.vmoptions. Each parameter to the VM should be on a new line of the file. For example, to set the minimum heap size to 512 MB and max VM heap size to 1024 MB, you’d use:

-Xms512m
-Xmx1024m

Sample file for Openfire running as a windows service attached.

Hie Sir.

I’m
afraid it didn’t work.

Is it necessary to save the file with the
extension txt or I can live like the attachment.

I even tried both
ways but none of them increased the memory amount in Java Machine for
Wildfire.

Please be sure I’m still using wildfire 3.1.1.

Looking forward for your
reply.

Best Regards Phone: +258 21467200
Mobile.: +258 826900420

You must leave the file as attached other than the actual content. Do not change the extension. For openfire you may want to read your install docs located in your Openfire directory. The install documentation should tell you how to do it for your system.

Also that file is specifically for users running openfire as a windows service. If you manually have to start openfire after logging into windows you need to rename the file as it says in the instructions included here:

To create parameters for the normal launcher, create a file called openfired.vmoptions (since the openfire.exe launcher invokes the openfired.exe executable to actually start the server).

Mtstravel, thanks for your help.

Works fine to me, im using wildfire 3.1.1 running as service. Just put the openfire-service.vmoptions in bin folder, restarted the service and now my wildfire process are using near 250mb of memory. Before this procedure, wildfire uses no more than 128mb, causing some crashes when have mare than 200 users online.

I’ll monitor the server for some days to see if crashes stop.

I have some doubts:

  • how can wildfire works with this openfire-service.vmoptions file? dont need to be something like wildfire-service.vmoptions?

  • ill upgrade to openfire 3.4.5 in some days (or weeks), will this file work in openfire version ?

Thanks in advance.

Gean