powered by Jive Software

How to background the openfire process

Hi @ all,

at the weekend i do an upgrade from 3.3.0 to 3.3.2. Until the last Upgrade the server proess switched into the background if he was started with the startscript (bin/openfire). Since the last Upgrade the Process will stay in the foreground. I tried to start it with bin/openfire start &, but unfortunely the process died eyery time i try to start on this way. i also have a look to implement the server as an service as in the readmes descriped, but there isn’'t an extra directory in the /bin directory, and no script…i have used the rpm of openfire on a suse 10.0 64 bit. thx

1 Like

Use

/etc/init.d/openfire { start | stop }

to control openfire.

P.S.

You can run every program in background, by append an ‘’&’’ at the end of your commandline:

./program --parameter&

thx, that is working for me…damned, i am only looking in /bin/ for the extra diretory for this script.

btw. i tried also to start like that: ./program --parameter& mostly lucky, but not with openfire.sh cause the process is always died when i tried to start.

now there is another problem, but i will make a new thread.

damned, i am only looking in openfire_home/bin/ for the extra diretory for this script.

If you want to use the ‘‘openfired’’ script, you can take the extra-Directory from the *.tar.gz

Coolcat