powered by Jive Software

How to Configure Remote XMPP Server Port

Hi,

How can we configure remote server port in openFire. I have a scenario where remote server is not running on default port 5269. I want to configure local openfire server to send connect request to a port different than default port.

Right now with openfire (3.4.1) local openfire server always send connect request on default port.

Regards

Pankaj

Hi Pankaj,

are the DNS SRV records for the remote server right? As far as I know Openfire looks for them and uses the returned values (port and host) to connect to the remote server.

LG

Hi LG,

Thanks for the response.

SRV record is configured correctly. It is configured with the default port.

Is there any way to overwrite the response ??

Regards

Pankaj

SRV record is configured correctly. It is configured with the default port.

Hi Pankaj,

Sorry, I didn’t really get what you mean. Do you actually mean that the SRV record is not configured correctly because what you want is a non-default port? If that is so, you have to modify the DNS SRV port number for that remote server. Do you have admin access to change the DNS config?

Hi Pankaj,

take a look at JM-711, it may help you to work around this problem.

LG

Hi LG,

Thanks for the response.

I tried following things and it still is not working:

  1. I followed instructions in JM-711 and added following system property:

dnsutil.dnsOverride {jabber.test.net,163.185.74.76:50423}

  1. I rebooted open fire.

  2. I still see DNS SRV and DNS Query Going out and Open Fire Picking those

values.

Please note i am using latest version of openFire.

Any Clue or pointer to debug it further.

Thanks

Pankaj

it2000

<forums@jivesoftw

are.com> To

                                   pantre <ptrehan@westell.com>       

11/13/2007 09:59 cc

AM

Subject

New message:

"How to Configure Remote XMPP

Server Port"

pantre,

A new message was posted in the thread "How to Configure Remote XMPP Server

Port":

http://www.igniterealtime.org/community/message/160162

Author : LG

Profile : http://www.igniterealtime.org/community/people/it2000

Message:

Hi Pankaj,

I did add this property and I did enable the debug log. When I try to connect to jabber.test.net it logs:

2007.11.17 12:52:25 OS - Trying to connect to jabber.test.net:5269(DNS lookup: 163.185.74.76:50423)

So for me this is working, using Openfire 3.4.1.

LG