powered by Jive Software

How to configure spark?

I apologize for such a lame discussion, but I cannot find simple installation instructions. I have openfire running successfully on an XP machine,

I would like to add spark. i installed the spark client and entered the IP address of the XP machine, user name and password, but no luck.

Any help would be appreciated.

Spark requires no configuration. It is all server side. You must setup openfire server completely (ideally with an world resolvable DNS name if there is even the remotest chance you want to access it from the internet).


  • Did you go to the openfire admin web site for your server and configure the server?
  • During the config did you give the server a name ( you should have used a FQDN like chatserver.domain.com)
  • Did you restart the server after finishing the config
  • Are you running the server as a service (otherwise you must remain logged into the XP machine at all times)
  • Did you punch holes for the server in the XP firewall
  • Are you entering the server name as you set it during config into spark

Thanks a million for the clear instructions.

For now there is no need to access it from the internet, so i installed spark on a local machin clicked on create new account, entered the server name i entered during installaion, disabled the firewall on the server, but still i get an error “cannot create an account”. I also forwarded the server ip to the port 9090 on the router. I also restatrted the PC.

Ifrogot to mention that it is indeed running as a service.

Update: I restarted the service, and now i get *connection to domain was dissconnected.


If you server’s name is not in a DNS (and not in this computers hosts file) then it cant find a server by its name. I suggest to login to server’s Admin Console and create first account for testing there. And then you cna try to login with this account in Spark. I think you should try using IP instead of of the server’s name in Spark login screen.

It works great now (i removed spark and resintalled it on the test box) thanks for all your help.