powered by Jive Software

How to enable pooling of SSL LDAP connections?

Guys i am using openfire 3.6.4 with Openldap, i use the SSL mode for authentication, i want to enable

connection pooling by default its true but as per ldap guide, its says

Note that if you turn on LDAP debugging, connection pooling will not be enabled. If SSL LDAP mode is enabled, you must set a system property to enable pooling of SSL LDAP connections.

http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/ldap-gui de.html

Note that if you turn on LDAP debugging, connection pooling will not be enabled. If SSL LDAP mode is enabled, you must set a system property to enable pooling of SSL LDAP connections.

I use below currently system properites regarding this

ldap.connectionPoolEnabled true

ldap.sslEnabled true

ldap.ldapDebugEnabled false

ldap.debugEnabled false

So as per guide i disabled teh ldap debugging but how i can confirm openfire use connection pooling on ssl

or what property need to enable as per above guide ?.

Thanks

Muzi

Guys please give suggestions on above.

Also suggest i need to change java system property, either its change by openfire system properites via web console ?

http://java.sun.com/products/jndi/tutorial/ldap/connect/create.html#TIMEOUT

com.sun.jndi.ldap.connect.timeout = 5000 (for 5seconds)

Or i need to do some extra thing for it ?

Please suggest. So much thanks.

Muzi

Please suggest guys where i go to solve my problem, i have now pain start in my head.

Please brothers suggest. What can i do to set ldap time out , failover auth not works also if primary ldap is down and for this

need to set java system property in openfire which i tried already via openfire system properties.

I am very thankful for all of this commuinty brothers and so much prayers to all of you.

Kindly give suggestions please please.