How to enable Service Discovery

Hello people! This is my first post!

I recently installed Openfire 3.7.0 on CentOS 5.5 i386.

I can connect with my xmpp user on him with Miranda, Pidgin, Exodus and Spark, but i have a little problem.

When i try to do a search on service discovery with Pidgin, i got a message “Server does not exist”, but Spark show the msn icon and i can log in.

What could be wrong? There is any configuration to do further than enable the msn gateway?

This is the debug from Pidgin when i try to do service discovery.

<iq type=‘get’ to=‘’ id=‘purpledisco32d7dee6’>

<query xmlns=‘’/>


<iq type=‘error’ id=‘purpledisco32d7dee6’ to=‘’ from=‘’>

<query xmlns=‘’/>

<error code=‘404’ type=‘cancel’>

<remote-server-not-found xmlns=‘urn:ietf:params:xml:ns:xmpp-stanzas’/>



Any ideas?


I can’t answer your question (maybe Pidgin devs can). Pidgin is a cursed client It is so often that something isn’t working just with that client… Why do you want to use MSN through a gateway if Pidgin (Miranda also) has a native MSN support?

Luke wrote:

<iq type=‘get’ to=‘’ id=‘purpledisco32d7dee6’>

The “to” attribute contains an IP, whereas an component (a jid) should be the case. The IP could mean that you try an service discovery with an link-local xmpp connection. So I suspect you did not choose the right endpoint in the pidgin GUI for the service discovery.

This is more an Pidgin related error. I personally don’t like libpurble. To quote wroot: “Pidgin is a cursed client”. Give Gajim or Psi a try.



I’m just testing the gateway option.

This could be interesting in a network where you don’t have access to msn/icq, and you can control who could have.


I already tested on Psi, and still can’t see the service discovery gateways.

The only client where it “worked” was Spark, but i thing that Spark has other way to connect to Openfire and use service discovery.

What Psi version do you use? Strange, but i can’t even login with Psi 0.10 to Openfire 3.7.0. I get such output

<?xml version="1.0"?>

<stream:stream xmlns:stream=“” xmlns=“jabber:client” to=“wroot” >

<?xml version='1.0' encoding='UTF-8'?>