powered by Jive Software

How to increase JAVA Memory in Openfire 3.3.2


#1

I have upgraded openfire server from 3.3.0 to Openfire 3.3.2 .

In previous versions I add following line in /opt/openfire/bin/openfire

INSTALL4J_ADD_VM_PARAMS="-Xms1024m -Xmx2048m"

but in Openfire 3.3.2 in can not find /opt/openfire/bin/openfire there in another file /opt/openfire/bin/openfire.sh

Now help to increase jave memory as default 64 Mb is very low.

Regards,

Shahzad Abid


#2

Now I am getting following error

Java heap space

RequestURI=/session-summary.jsp

Caused by:

java.lang.OutOfMemoryError: Java heap space

Powered by Jetty://


#3

Greetings,

Add a line like this in /etc/sysconfig/openfire

OPENFIRE_OPTS="-Xms256m -Xmx512m"

daryl


#4

Thanks buddy it works!


#5

For some reason I am not locating these files

Im running Openfire 3.3.2, Windows XP . using a MySQL DB


#6

See install-guide.

Custom Parameters

Advanced users may wish to pass in parameters to the Java virtual machine (VM) to customize the runtime environment of Openfire. You can do this by creating vmoptions files in the bin/ directory of your Openfire installation. For the Windows service, you’‘d create a new text file called openfire-service.vmoptions. Each parameter to the VM should be on a new line of the file. For example, to set the minimum heap size to 512 MB and max VM heap size to 1024 MB, you’'d use:

-Xms512m

-Xmx1024m

To create parameters for the normal launcher, create a file called openfired.vmoptions (since the openfire.exe launcher invokes the openfired.exe executable to actually start the server).


#7

glish_dreams wrote:

For some reason I am not locating these files

Im running Openfire 3.3.2, Windows XP . using a MySQL DB

If you are using windows, in the bin folder under your openfire directory, you need to create/edit 1 of two files.

If running via the GUI console, create/edit the file ‘‘openfired.vmoptions’’.

In this file, add the following lines…

-Xms512m

-Xmx1024m

If you are running as a service, copy the file to another file named, ‘‘openfire-service.vmoptions’’.

Hope this helps.

Message was edited by: ldove