How to install openfire via SSH (Putty)

I’m new for openfire and linux thing. i need complete steps to install openfire to my vps host. including JDK. Please help me i can access via SSH and i use Putty. Thank you


cd /tmp

wget ‘ .i386.rpm

sudo rpm -ivh openfire-3.7.0-1.i386.rpm

sudo /sbin/service openfire start


Message was edited by: Daryl Herzmann to remove the old link


Impressive. Thanks for help.

Hello I follower your instructions and all i changed was the URL:

so i

cd /tmp

wget ire-3.7.0-1.i386.rpm

and not i am trying to do the sudo rpm -ivh openfire-3.7.0-1.i386.rpm

but is giving me this error:

error: open of openfire-3.7.0-1.i386.rpm failed: No such file or directory

Is basically saying that there is not such file / folder and is true. It is not such folder or file in my server.

But the download was completed correctly.

I also tried URL wget .i386.rpm

Still same error I can not proceed with the sudo rpm -ivh openfire-3.7.0-1.i386.rpm

Please help me …

Thank you!

The ? in the URL is probably causing you grief. Quote the URL

wget -O openfire-3.7.0-1.i386.rpm ‘ .i386.rpm


Thank you very much for your fast respond.

Im uploading it manually and i will sudo it soon.


Again an issue:

I did

sudo rpm -ivh openfire-3.7.0.beta-1.i386.rpm

and I get the following code: is that what I am supposed to get.

Usage: rpm [-aKfgpWHqV] [-aKfgpWHqVcdils] [-aKfgpWHqVcdilsaKfgpWHqV] [-aKfgpWHqVcdilsaKfgpWHqV] [-aKfgpWHqVcdilsaKfgpWHqV] [-aKfgpWHqVcdilsaKfgpWHqVK] [-aKfgpWHqVcdilsaKfgpWHqVK] [-aKfgpWHqVcdilsaKfgpWHqVKi] [-aKfgpWHqVcdilsaKfgpWHqVKiv] [-aKfgpWHqVcdilsaKfgpWHqVKiv] [-aKfgpWHqVcdilsaKfgpWHqVKiv?] [-a|–all] [-f|–file] [-g|–group]

[-p|–package] [-W|–ftswalk] [–pkgid] [–hdrid] [–fileid]

[–specfile] [–triggeredby] [–whatrequires] [–whatprovides]

[–nomanifest] [-c|–configfiles] [-d|–docfiles] [–dump] [-l|–list]

[–queryformat=QUERYFORMAT] [-s|–state] [–nomd5] [–nofiles]

[–nodeps] [–noscript] [–comfollow] [–logical] [–nochdir]

[–nostat] [–physical] [–seedot] [–xdev] [–whiteout]

[–addsign] [-K|–checksig] [–delsign] [–import] [–resign]

[–nodigest] [–nosignature] [–initdb] [–rebuilddb] [–aid]

[–allfiles] [–allmatches] [–badreloc] [-e|–erase +]

[–excludedocs] [–excludepath=] [–fileconflicts] [–force]

[-F|–freshen +] [-h|–hash] [–ignorearch] [–ignoreos]

[–ignoresize] [-i|–install] [–justdb] [–nodeps] [–nomd5]

[–nocontexts] [–noorder] [–nosuggest] [–noscripts]

[–notriggers] [–oldpackage] [–percent] [–prefix=]

[–relocate==] [–repackage] [–replacefiles]

[–replacepkgs] [–test] [-U|–upgrade +] [–quiet]

[-D|–define ‘MACRO EXPR’] [-E|–eval ‘EXPR’] [–macros=<FILE:…>]

[–nodigest] [–nosignature] [–rcfile=<FILE:…>] [-r|–root ROOT]

[–querytags] [–showrc] [–quiet] [-v|–verbose] [–version]

[-?|–help] [–usage] [–scripts] [–setperms] [–setugids]

[–conflicts] [–obsoletes] [–provides] [–requires] [–info]

[–changelog] [–xml] [–triggers] [–last] [–dupes]

[–filesbypkg] [–fileclass] [–filecolor] [–filecontext]

[–fscontext] [–recontext] [–fileprovide] [–filerequire]

[–redhatprovides] [–redhatrequires] [–buildpolicy=]

[–with=] [–without=]

Then i try to sudo

[~/tmp]# sudo /sbin/service openfire start

And I get:

openfire: unrecognized service

thank a lot for your help.