powered by Jive Software

How to make openfire server visible for non-local user

Hi community,

I have a problem setting up an online(not only local network) openfire xmpp server.

I installed openfire on windows.It is set up everything correctly for local network. It worked fine and I was able to chat.

Now my goal is to host an online server. I setup a dynamic dns account on no-ip.com. It syncroizes well my external ip with my fritz box.

I set up an new openfire server on my windows pc and entered in the domain field during installation process my no-ip.com address (myadress.no-ip.biz)

Then I connected to the Admin Console. Server Information says:

Server Name: myadress.no-ip.biz

Host Name: Win-PC (my local computer name)

To connect via xmpp to my second server I need to enter my locals pc IP (192.168.178.x)

How can I change that(Host Name)? I want to enter my external ip (92.192.xx.xx). I also want others to be able to do so.

I hope my problem is clear!

Please help me. Thank you in advanced.

Sandra

Configure your fritz box to allow incoming connections from the external IP, port 5222 and map them to your internal IP, port 5222. Then you should be able to connect to Openfire using the server name.

Thank you, I also did this in the morning and it worked fine. I also opened other ports for major things.

I was busy setting up the server, so I wasnt able to tell this topic is already answered.

But thanks for your answer! Perhaps it will help other people with the same problem.

Sandra