powered by Jive Software

How to prevent the creation of the rooms in openfire, without administrative privileges

Hi, I’ve a question.
It’s possible to configure that only users, that have administrative permission, can create new rooms?
At this time, I’ve set this:
GROUP CHAT ->GROUP CHAT SETTINGS -> ROOM CREATION PERMISSIONS ->PERMISSION POLICY -> ONLY SPECIFIC USERS/GROUPS CAN CREATE CHAT ROOM.
but currently any registered user can enter and create a new room.
It’s normal?
Where is the correct setting to prevent this?

Thanks for attention.
Best regards.
Massimo

You should add someone (at least one group or one user) to the allowed list.

Sorry but i don’t understand.
When I create a new user, shouldn’t be a standard user (so “limited”)?
Special “features” to create (and/or administer the room) should not be assigned to you by another party or still assigned to specific and trusted users?
At this moment every new user, once has logged-in , have a possibilities to create a new room.
I havn’t found a place to restrict this.
Can you help me?

Very thanks for attention.
Massimo

If you don’t want evey user to be able to create rooms, you must add someone to the allowed list. It just works thia way. If you don’t add anyone there it doesn’t block anything. So add yourself or some user you create just for that.

OF-1392

Sorry but I don’t find where is the allowed list.
Which is the menu where I find this settings?
Best regards.
Massimo

Admin Console > Group Chat > Group Chat Settings > press on you conference service > Room Creation Permissions > check “Only specific users/groups can create a chat room.”, press Save Settings. Add some users or a group to allowed list and save again.

Openfire 4.5.1
Ofmeet / Pade VideoBridge Plugin 0.9.8

This is not working for me.

I followed the instructions.

Only specific users/groups can create a chat room.

Added two users to Allowed Users/Groups.