How to reset admin access - Lost all Admin access

I’m not shure that this i the right forum, but I’m trying:
Running Openfire 4.6.4 on MS SQL db. With AD integration.
Chat server is running, no users have noticed disruptions.
We think that some one by accident have cleared the list of administrators.

We have looked at db tabels and local files on the server to se if we can roll backup either db og server to a point with admin access, but haven’t found a clue.

Any better idea ?

you coud add a user directly to the openfire database > table ofUser
or you start setup again and set an admin (use the same database will keep your preferences then)…

The Admin users are in the db.
If I try to log on as a non admin user i can see it in the logs that access has been denied.
If I or we try to logon as admin, it keeps trying to connect, Forever. And nothing is commited to logs.

Then i would run setup again…
you could do this by changing the tag “setup” to “false” in the openfire.xml which you will find in the openfire/conf dir. After that restart openfire and setup will be started on port 9090.
The next step is to setup OF again, use the same preferences as you did on the first time and at the last page you are able to set a new admin.

Thanks for the input.
We have tried to reinstall, latest 4.6.5 on server 2016, on the original db (MS SQL).
In final part of setup, I add admin users, and test that the admin user is valid.
But still after setup completes. The user has no acces to admin console.
We have tested on a new db, same result.
We finish install, and loose access to admin console.

That almost sounds like the changes are not taking effect. Can you log in with the default admin/admin password? If that’s the case, then you might be running into some kind of file permission issue, preventing changes to be persisted.

As an aside: the best way to re-gain access to Openfire in case of a lost password scenario is described in

Hi Expert,

My Admin account got deleted accidentally, I Performed your advise :slight_smile: rerun the setup, stop Openfire, edit /conf/openfire.xml, change the last tag (setup) to false, then run it again and launch the Admin Console url where it as asking previous admin password and here i strucked because that user is deleted.
Can you plz suggest more to fix it ?

To temporarily restore access to the admin console of Openfire, you can configure Openfire to use a a One-Time Access Token. This process is described in which I had already linked in my previous message.

With this temporary access, you can then recreate and admin user, or reset the password of an existing user.