powered by Jive Software

How to upgrade openfire 3.6.4 to 3.81

Hi ,

Any body idea how to upgrade openfire 3.6.4 to 3.8.1 … please suggest… if have any docs … please share…

Thanks,

Rao…

On the most part, you can just download 3.8.1 and start it up - Ensure you copy back your conf/openfire.xml otherwise it’ll take you through the setup process again (and maybe connect to the wrong database).

If you are using any non-standard plugins you may want to check to see if they have updates. As always, back everything up first in case it doesn’t go as smoothly as planned.

1 Like

Hi David,

Thanks for response, i have small doubt do you have any idea which is major changes in 3.6.4 to 3.8.1… ?

Thanks in advance:)

Rao.

If you want to know what is different, check the changelog: http://www.igniterealtime.org/builds/openfire/docs/latest/changelog.html

For what it is worth, we started out at 3.6.4, went to 3.7.0 then 3.7.1 - We stayed there until this weekend, and we’re on 3.8.2 (from SVN) now. On the most part nothing changes from a user perspective.

Hi David,

Thanks for update, and Could i upgrade my openfire version directly from 3.6.4 to 3.8.2. or i need to upgrade step by step like 3.7. and 3.7.1 etc… Could you suggest me on this and how much time it will take to upgrade…

Eevn a m planing to upgrade my spark version also…

Thanks,

Subbarao…

.

You should be able to go straight from 3.6.4 to 3.8.1 without any issues, assuming you are only using the bundled plugins.

Time for the upgrade depends on you and your environment. I usually budget 2 hours for backups, upgrade, testing and time for rollback. Usually takes closer to 15mins though.

Hi David,

Thanks for giving clear idea… but i am facing some i am not able to view fastpath webchat… in 3.81.

Thanks,

Rao

Ensure you copy back your conf/openfire.xml otherwise it’ll take you through the setup process again (and maybe connect to the wrong database).

At least on Windows the installer doesn’t overwrite this file, so no setup process is shown after the upgrade.

Hi,

I am not able to view fastpath webchat plugin openfire 3.8.1

I think i saw another report about webchat problems with 3.8.x. Probably something got broken in the changes with 3.8. But there is little chance someone will look into this soon. So, i suppose you did a backup? You can go back to 3.6.4 and then maybe upgrade just to 3.7.1.

Hi Wroot,

Thanks for update… could you share me where will i get the openfire 3.7.1 source code and compatable source code of fastpath webchat…

Do you have any idea why fastpathe webchat is not displying in openfire end…Do you have any idea is there any new version release for openfire(in this month)…

Thank,

RAO.

Well, you can find the source here (via SVN) http://www.igniterealtime.org/downloads/source.jsp but i don’t know how to get 3.7.1 version from there. Not a developer myself. If you want an 3.7.1 installer, just replace 3.8.1 in the download link to 3.7.1. 3.8.2 maybe be in this month or not, but i don’t remember anything about webchat being fixed.

ok ,Thanks Wroot,

Could you help me how will i Track webchat issue in 3.8.1…

Thanks,

Rao,