HTTP 500 Error after creating ADMIN account page


This is not good. A wildfire sysop swore up and down how much better this was over ejabberd and it installs in seconds. So we downloaded it and we spent over 1 hr trying to get pass this HTTP 500 error after the admin page. Googled HTTP 500 WildFire and found some articles/threads about having the machine/domain name in the HOSTS. It was and it also in our DNS server and every applet resolvers it, including DNS lookups, ping, etc.

I then, on my own, tried it again, and again, and on different machines with the same on going HTTP 500 error.

What gives? I want to give this package a try before I give on it?



which OS are you using?

Are you using Intel i386, AMD64 or PowerPC?

Which file did you download?


I tried it on two machines:

One is Windows 2003 Server 100% updated and the other Windows XP SP2 workstation 100% updated.

Both at Intel P4 Dual core, although it has the EM64T (AMD64 clone), 32 bit windows is installed. Not 64 bit.

Downloaded wildfire_3_1_0.exe and the, tried both just in case it was a JRE issue. Both machines have the latest JRE v5 from SUN. I will note that the JRE was auto-updated yesterday. I gave that a thought, but I didn’‘t see an easy way to revert and I wasn’'t to waste time with that for this.

I checked the HOSTS file as some messages referred to.

We are thinking of including a Jabber server with our 25+ year old Wildcat! Hostng system. I’'ve had ejabberd installed and running when a customer recommended we try WildFire. Since he said he was easy to install, we allowed him access to our server to install it. I watched and over 1 hour time trying everything we can, including temporary stopping all security stuff. We gave up. I then downloaded to my XP workstation and had the same issues there as well. Go Figure.

I exhausted my technical know how for this simple thing.


Hey HLS,

Wildfire 3.1.1 is out! Could you try using the very latest version and see how it goes? We made same changes and improvements to the setup pages for this version. Anyway, if you are still getting the error 5005 (i.e. internal error) then check your log files for errors and post any relevant error that you found.


– Gato

Sorry, This 3.1.1 version didn’'t work.

Same HTTP 500 issue after the admin creation page.

Can any of the developers back trace the source code where this 500 error begins and provide the possible reasons for this?

The best I can give you is this:


2006.10.30 01:59:07 Wildfire 3.1.1

2006.10.30 01:59:12 Admin console listening at:

2006.10.30 01:59:45 Missing database schema for wildfire. Attempting to install…

2006.10.30 01:59:45 Database update successful.


01:59:50.968 WARN!! [SocketListener0-0] org.mortbay.jetty.servlet.ServletHandler.handle( >11> /setup/setup-finished.jsp:


at org.jivesoftware.wildfire.admin.setup.setup_002dfinished_jsp.jspService(setup

at org.apache.jasper.runtime.HttpJspBase.service(

at javax.servlet.http.HttpServlet.service(

at org.mortbay.jetty.servlet.ServletHolder.handle(

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage( 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at org.jivesoftware.util.LocaleFilter.doFilter(

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at org.jivesoftware.admin.PluginFilter.doFilter(

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at org.jivesoftware.admin.AuthCheckFilter.doFilter(

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:471)

at org.mortbay.jetty.servlet.ServletHandler.handle(

at org.mortbay.http.HttpContext.handle(

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:633)

at org.mortbay.http.HttpContext.handle(

at org.mortbay.http.HttpServer.service(

at org.mortbay.http.HttpConnection.service(

at org.mortbay.http.HttpConnection.handleNext(

at org.mortbay.http.HttpConnection.handle(

at org.mortbay.http.SocketListener.handleConnection(

at org.mortbay.util.ThreadedServer.handle(

at org.mortbay.util.ThreadPool$


Ok, I dug deeper. I don’'t know what problem was happening with the creation of the admin account during the first time “Launch Admin” failed, but this is how I was finally able to get going.

At home, I installed this on a LAN workstation, computer name: HDEV21, ip, DHCP assigned by firewall/router.

First, just in case, I used the EXE installer and allowed it to use the default Windows Program Files folder, just in case, the code was looking for something specifically in this folder.

Second, I use the "Skip this part’’ or whatever was the prompt for creating the admin account. I would deal with this later if can I get pass it.

The HTTP 500 error still occured.

Third, noticing the server was running, I used Exodus to get in. I noticed that it had that it would use instead of HDEV21, for my JID, hector@hdev21

Forth, I closed all windows, stop the server and restarted. Noticed the “Missing the Database schema… successful install” message. Launched Admin and this time I got the login prompt. It wouldn’'t take any combo account, include admin/admin, etc.

Forth, I found the /documentation/db-integration-guide.html and read about the conf\wildfire.xml file. Stopped the server, edited the XML file and added:

saved, and restarted the server.

Now I was able to login as the admin using this user account.

I really can’'t tell what is the cause of the initial problem, name resolution perhaps? I should possibly try a fresh install with the admin account "admin@" I had tried admin@hdev21, even left the default it put there (bad idea, IMO)

But fellas, this should not be such a PITA for what seems to be a real nice package.

BTW, I did try changing the hosts file to localhost hdev21

Windows XP still pinged instead. I will say that Microsoft has changed the order of its lookups over the years. I can’‘t recall off hand since I haven’'t program this aspect in awhile, but using the Windows socket layer in today windows will use the local cache rather than DNS first. So you have to flush it with IPCONFIG /FLUSHDNS to get a fresh copy from DNS.

I would like to get all this resolved before trying to install it on our server at where I had ejabberd currently running.


One last thing I forgot the mention. Your BROWSER must have cookies enabled.

This should be an easy change to the login code to check for cookie settings and display a warning.

Not everyone keeps the browser’'s default of “Allow Cookies” I use exceptions only.



which database are you using? I wonder if you did create the tables but did not insert the jiveversion and jiveuser values. (Missing “commit;” or no autocommit).


No, I used the native DB engine. I wanted to get it going because going to an external db interface.