powered by Jive Software

Http-bind [] Need a little hand holding to get my code happening

I’'m trying to learn enough to write some interface scripts

for wildfire/openfire . After reading the specs for the zillionth time

and googling myself to death, I’'m turning to you all to help me understand ther errors in my

ways.

Below is the current dump of my HTTP-BIND transactions. I’'m getting

some way into it , but still not yet getting the expected results.

It would be nice once I do figure it out to post a nice blow by blow tutorial

outlining what I’‘ve learned. But heres where I’‘m at. I’'ve tried passing the login as plain text , base64

and other permutations and I’'m just stuck.

CWchat::createHTTPsession() ===

Send

======

POST /http-bind/ HTTP/1.1

Accept: /

Host: 71.6.152.69

Content-Type: text/xml; charset=utf-8

Content-Length: 176

createXMPPauthentication===

Send

======

POST /http-bind/ HTTP/1.1

Accept: /

Host: 71.6.152.69

Content-Type: text/xml; charset=utf-8

Content-Length: 152

createXMPPchallenged

Send

======

POST /http-bind/ HTTP/1.1

Accept: /

Host: 71.6.152.69

Content-Type: text/xml; charset=utf-8

Content-Length: 194

[Powered by Jetty:// | http://jetty.mortbay.org/]

HTTP ERROR: 404

Invalid SID.

RequestURI=/http-bind/

Powered by Jetty://

I don’‘t see any obvious problem. Unfortunately, Alex (the guy that implemented http bind) is out of town on vacation. One suggestion I’'d have is to download the SparkWeb beta plugin and examine the traffic that it sends back and forth to the server. Maybe that will give you some good clues in the short term.

Regards,

Matt

That’'s sorta a bummer for an initial response.

I was sorta hoping for a “Dah you forgot XXX and a smiling back hand”

On the other hand it does feel good not to be stupid out the box, however it

does leave me with the task to solve.

I’'ll look into the sparweb tool. So your saying that the sparkweb tool has a break out feature

or that I should use one of my other tools to monitor it’'s traffic?

TIA

–Doc

Well, just to qualify my answer, it’‘s very possible that Alex could look at the protocol flow and know the issue in 10 seconds, heh. Sparkweb doesn’'t have a debug feature that I know, but you should be able to use a tool like Firebug or an http proxy to look at all the protocol traffic between the client and server.

Regards,

Matt

Hey Drclue:

Notice any errors in the openfire error logs? My guess is that openfire is is clossing the session for some reason and the client isn’'t being notified.

Thanks,

Alex

The last errors in the log were

2007.05.04 09:05:50 org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java: 462) Error loading plugin: /opt/openfire/plugins/search

java.lang.NullPointerException: No ComponentManager implementation available.

at org.xmpp.component.ComponentManagerFactory.getComponentManager(ComponentManager Factory.java:52)

at org.jivesoftware.openfire.plugin.SearchPlugin.initializePlugin(SearchPlugin.jav a:102)

at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :404)

at org.jivesoftware.openfire.container.PluginManager.access$200(PluginManager.java :46)

at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:916)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

2007.05.04 09:06:10 org.jivesoftware.util.log.util.CommonsLogFactory$1.fatal(CommonsLogFactory.java: 95) The scratchDir you specified: /tmp/Jetty_0_0_0_0_8080_spank____dkf8ts/jsp is unusable.