Http bind with Openfire 3.6.4 and SparkWeb 0.9

Hello everybody.

I have just installed Openfire 3.6.4 and SparkWeb 0.9. Everything works fine inside my network, but now I am trying to activate http binding for external users to use only port 80 (to avoid firewall problems).

I have change SparkWeb.html to these settings:

function jive_sparkweb_getConfig()


return {

server: “yourpublichostnamesite”,

location: window.location.href,

connectionType : “http”,

port: “80”,

bindPath: “/http-bind/”,

autologin: “false”,

policyFileURL: “http://yourpublichostnamesite/crossdomain.xml


Created crossdomain.xml inside /www/var/sparkweb folder for apache2:

And did proxy:

ProxyPass /crossdomain.xml http://sparkServerInternalIP/sparkweb/crossdomain.xml

ProxyPassReverse /crossdomain.xml http://sparkServerInternalIP/sparkweb/crossdomain.xml

ProxyPass /http-bind/ http://sparkServerInternalIP:7070/http-bind/

ProxyPassReverse /http-bind/ http://sparkServerInternalIP:7070/http-bind/

Http binding is enabled and BOSCH disabled.

When I try to login from web client, the page does not respond anything (no errors) and I do not see any errors on the logs (if I do not use http binding and use socket to 5222, everything is fine).

Is there any problem with these versions of openfire and sparkweb for http bind?

What am I doing wrong?

Thanks in advance.