powered by Jive Software

HTTP Binding - Problem with IE only?

Hi,

I have a very strange problem (don’‘t think it is a problem with Wildfire) that I can’'t pinpoint and wanted to see if anyone else is seeing similar issues.

I am using Wildfire http-bind with JSJAC client libraries. Everything is working 100% in Firefox.

But in IE, it stops working after about 10 to 20 messages.

The problem is that the xmlhttprequest request to the wildfire server locks up, and the readystate doesn’'t change when it should. I never get the response back and the eventual result is:

HTTP ERROR: 404

Unexpected RID error.

being returned by Wildfire.

If I run fiddler on the client (which is an effective proxy) then the problem just never occurs. Somehow fiddler corrects this behaviour making it extremely hard to find out what is happening.

I have tried using various httprequest objects and the new native one in IE7. Makes no difference.

This problem doesn’'t seem to occur when running in a fast LAN environment, but does on our production servers which are located overseas.

Thanks

Daniel

Which version of Wildfire/Openfire are you using? Do you see anything in your error logs?

Thanks,

Alex

I have upgraded to the latest version.

There are no errors in the logs.

Problem never happens in Firefox - only in IE.

Thanks

Daniel