HTTP ERROR: 500 when trying to access the Users/Groups tab

I just installed the current version of Wildfire server on a Windows 2003 server. Everything seemed to be fine until I tried to access the Users/Groups tab on the web admin page. It’‘s failing to load http://192.168.1.2:9090/user-summary.jsp. Below is what I see in my browser. I’'m accessing the user/groups tab hoping to create a new user.

HTTP ERROR: 500

Internal Server Error

RequestURI=/user-summary.jsp

Powered by Jetty://

I noticed I was getting a done of illegal exception errors in the server console. Due to this I download the newest version of Java, I now get the below errors.

java.lang.IllegalArgumentException: Illegal JID: drexel_2

at org.xmpp.packet.JID.init(JID.java:401)

at org.xmpp.packet.JID.(XMPPServer.java:147)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.wildfire.starter.ServerStarter.start(ServerStarter.java:88)

at org.jivesoftware.wildfire.starter.ServerStarter.main(ServerStarter.java:49)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown

I fixed it. I had an underscore in my server name. It resulted in the below error:

java.lang.IllegalArgumentException: Illegal JID: myserver_2

I took the underscore out of the domain name and it works now.

awsome!

Hi there- can you please be more specific as to how you solved this issue?