powered by Jive Software

Http error: 500

Hi @ all,

after upgrading from 3.3.0 to 3.3.2 an starting the server (etc/init.d/openfire start) the adminconsole point me to the setup. after inserting the database information (mysql) in the next window (where i should insert where to store the profile setting) i choose to store it in the default location (openfire database). when i hit the next button to come the the administration account i get the following error:


schnipp----


HTTP ERROR: 500

INTERNAL_SERVER_ERROR

RequestURI=/setup/setup-profile-settings.jsp

Caused by:

java.lang.NullPointerException

at org.jivesoftware.util.JiveGlobals.deleteXMLProperty(JiveGlobals.java:492)

at org.jivesoftware.openfire.admin.setup.setup_002dprofile_002dsettings_jsp._jspSe rvice(setup_002dprofile_002dsettings_jsp.java:75)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:491)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1074)

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:65)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:69)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:365)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:185)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:689)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:391)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:146)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.Server.handle(Server.java:285)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:457)

at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:765 )

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:627)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:203)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:357)

at org.mortbay.jetty.bio.SocketConnector$Connection.run(SocketConnector.java:217)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:475)

Powered by Jetty://


schnapp----


someone can help me out? i try to run openfire on a vserver with suse 10.0 64bit. openfire 3.3.0 works well for some month. thx

Message was edited by: betamax

ok…i did a downgrade to 3.3.0 and that is working for me very well…

Hi, I had the same problem.

I figurate that a openfire daemon start up when I turn on the computer(Fedora C6), is that the reason that when i installed openfire i didn’'t have this problem.

So in the command line write:

#ps aux | grep openfire

see what is the PID and kill that procces.

#kill

then start openfire from the script:

  1. cd /opt/openfire/bin

  2. ./openfire.sh start

That is all, and it works.

Please, I’‘m newbe on linux, so if someone knows how to stop that the openfire daemon start up when the computer turn on, make me know. (sorry by my english, i’'m latinamerican).

Att: Laura Zapata Aspiazu.

Babahoyo-Ecuador