powered by Jive Software

I can''t log in to my ejabberd v0.91 server

Hi you all!

I don’'t know if its a smack or ejabberd problem…

After migrating to ejabberd v0.91 my small web-based client can`t log any user… (with the previous version, 0.75 it worked…)

I have a small web-app that logs into an account and look for new

offline messages. I’'ve used JIVE SOFT smack library. After migrating

to v0.91 this application never get answer from the server when it’'s

trying to connect… Does new ejabberd need any special

configuration?? Does any of you probe this feature against ejabberd v0.91?

I got this in ejabberd console…

=INFO REPORT==== 6-Jun-2005::17:45:25 ===

I(<0.244.0>:ejabberd_listener:90): (#Port<0.342>) Accepted connection

{{172,16,2,190},3158} -> {{172,16,1,25},5222}

and this is my config file:

% $Id: ejabberd.cfg.example 332 2005-04-27 01:08:18Z alexey $




% Users that have admin access. Add line like one of the following after you

% will be successfully registered on server to get admin access:

%{acl, admin, {user, “aleksey”}}.

{acl, admin, {user, “mmarin”}}.

% Blocked users:

%{acl, blocked, {user, “test”}}.

% Local users:

{acl, local, {user_regexp, “”}}.

% Another examples of ACLs:

%{acl, jabberorg, {server, “jabber.org”}}.

%{acl, aleksey, {user, “aleksey”, “jabber.ru”}}.

%{acl, test, {user_regexp, “^test”}}.

%{acl, test, {user_glob, “test*”}}.

% Only admins can use configuration interface:

{access, configure, }.

% Every username can be registered via in-band registration:

%{access, register, }.

% After successful registration user will get message with following subject

% and body:



"Welcome to Jabber Service. "

“For information about Jabber visit http://jabber.org”}}.

% Replace them with ‘‘none’’ if you don’'t want to send such message:

%{welcome_message, none}.

% List of people who will get notifications about registered users

%{registration_watchers, [“admin1 at localhost”,

% “admin2 at localhost”]}.

% Only admins can send announcement messages:

{access, announce, }.

% Only non-blocked users can use c2s connections:

{access, c2s, [{deny, blocked},

{allow, all}]}.

% Set shaper with name “normal” to limit traffic speed to 1000B/s

{shaper, fast, {maxrate, 1000}}.

% Set shaper with name “fast” to limit traffic speed to 50000B/s

{shaper, fast, {maxrate, 50000}}.

% For all users except admins used “normal” shaper

{access, c2s_shaper, [{none, admin},

{normal, all}]}.

% For all S2S connections used “fast” shaper

{access, s2s_shaper, }.

% Admins of this server are also admins of MUC service:

{access, muc_admin, }.

% All users are allowed to use MUC service:

{access, muc, }.

% This rule allows access only for local users:

{access, local, }.

% Authentification method. If you want to use internal user base, then use

% this line:

%{auth_method, internal}.

% For LDAP authentification use these lines instead of above one:

{auth_method, ldap}.

{ldap_servers, [“”]}. % List of LDAP servers

{ldap_uidattr, “uid”}. % LDAP attribute that holds user ID

{ldap_base, “o=empleados,o=juntadeandalucia,c=es”}. % Search base of

LDAP directory

{ldap_rootdn, “cn=jsanchez,o=juntadeandalucia,c=es”}. % LDAP manager

{ldap_password, “pass”}. % Password to LDAP manager

% For authentification via external script use the following:

%{auth_method, external}.

%{extauth_program, “/path/to/authentification/script”}.

% For authentification via ODBC use the following:

%{auth_method, odbc}.

%{odbc_server, “DSN=ejabberd;UID=ejabberd;PWD=ejabberd”}.

% Host name:

{hosts, [“svrjuntanet”]}.

% Default language for server messages

{language, “en”}.

% Listened ports:


[{5222, ejabberd_c2s, [{access, c2s}, {shaper, c2s_shaper},

starttls, {certfile, “./ssl.pem”}]},

{5223, ejabberd_c2s, [{access, c2s},

tls, {certfile, “./ssl.pem”}]},

% Use these two lines instead if TLS support is not compiled

%{5222, ejabberd_c2s, },

%{5223, ejabberd_c2s, [{access, c2s}, ssl, {certfile, “./ssl.pem”}]},

{5269, ejabberd_s2s_in, },

{5280, ejabberd_http, },

{8888, ejabberd_service, [{access, all},

{hosts, [“icq.localhost”, “sms.localhost”],

[{password, “secret”}]}]}


% If SRV lookup fails, then port 5269 is used to communicate with remote server

{outgoing_s2s_port, 5269}.

% Used modules:



{mod_register, },

{mod_roster, []},

{mod_privacy, []},

{mod_configure, []},

{mod_configure2, []},

{mod_disco, []},

{mod_stats, []},

{mod_vcard, []},

{mod_offline, []},

{mod_announce, },

{mod_echo, [{host, “echo.localhost”}]},

{mod_private, []},

{mod_irc, []},

% Default options for mod_muc:

% host: “conference.” ++ ?MYNAME

% access: all

% access_create: all

% access_admin: none (only room creator has owner privileges)

{mod_muc, [{access, muc},

{access_create, muc},

{access_admin, muc_admin}]},

{mod_pubsub, []},

{mod_time, []},

{mod_last, []},

{mod_version, []}


% Local Variables:

% mode: erlang

% End:

I’'m trying to connect to the server bty port 5222 and using username =


Any ideas?

Thanks a lot in advance!

Miguel Angel Marín