powered by Jive Software

I have an issue with making Openfire work externally

Hello all,

I have set up and installed Openfire on to one of my Windows Servers. (W-Server 2003) & I have created a MySQL database through MySQL Workbench to hold the installation of Openfire.

The installation was successful and I was able to easily configure Openfire through the administration panel.

However, this is the part which started to confuse me. I want to be able to configure Openfire so that users from other houses can connect to spark through my network. I have searched around the forums already for information on how to do this… However, I my users are still receiving this error “Cannot connect to server: invalid name or server not reachable”

Here are the steps I’ve preformed so far:

  • Configured my Windows Server domain (AD) to match the real world sub-domain. (connect.keolia.co.uk)

  • I forwarded the sub-domain to match the DNS IP of my server.

  • I enabled “Server to Server” and “Connection Manager” on Openfire.

  • I added 2 custom services to my router (Both port: 5222, 5269 and 5223

  • Finally, I opened up all 3 ports on the Firewall Rules area of my router.

At the minute my chat server will only connect internally and will not externally… would anyone be able to point me in the right direction in making my server publically accessable.

Many thanks,

Joshua Walker.

Hi Joshua,

are you a BOFH?

A private IP address will never be routed in the internet. Use the public IP address instead for your DNS record so one can connect to your router.

LG

Configured my Windows Server domain (AD) to match the real world sub-domain

What does this mean? %COMPUTERNAME% and the %DOMAIN% can be whatever they want to be. Openfire uses its own xmpp.domain which has nothing to do with your system settings. I assume that the xmpp.domain is “connect.keolia.co.uk” and so this is the domain name the clients should use to connect.

I enabled “Server to Server” and “Connection Manager” on Openfire

Why? Did you install a connection manager? Do you want that your server connects to other xmpp servers? If you do you may want to use SSL certificates.

Hello,

Well…at the moment my public IP is dynamic…so is there anyway to get around this as my ISP doesn’t provide static IP addresses.

Cheers,

Josh.

Edit: would no-ip or DynDNS work as a virtual static name?

(As I am needing something that will automatically update the IP on the sub-domain every time I connect to the Internet)

Message was edited by: Joshua Walker

Hi Josh,

simple update the public DNS record every time your IP address does change and make sure that the DNS record TTL is low, maybe 15 minutes.

LG

Hello,

Okay, thanks for that information. Although, would it be possible to use to a service such as no-ip to do the manual work of updating my IP for me?

Thanks,

Josh.

BTW: I have updated the DNS records to point to my external IP… should this now work the way I’m wanting it to or is there anything else that I have missed out?

Hi Josh,

it should work but it does not - maybe your IP did already change again. Or your router configuration is not yet complete.

I don’t know who is using a public server like this, anyhow it may be possible to create a CNAME for your xmpp.domain which points to a public DNS record.

LG

Hello,

Right, well thanks for the infomation. I’ll give it a shot now I’ve a few modifications and I will let you know how things went.

Cheers,

Josh.

Update: Your advise worked mate! Just updated the DNS record to point towards my external IP and now my spark server is publically accessable.

Thanks again mate,

Josh.