powered by Jive Software

I want to change the cache size for following two properties

I want to update the following two properties, Though I have the list properties in that list following two components are missing, and also gone through the Openfire code but not able to find the following two components. that are
Components, and Client Session Info Cache

The general format of these are

cache.<nomalised cache name>.maxLifetime (in milliseconds) and
cache.<nomalised cache name>.size (in bytes)

Where <nomalised cache name> is the cache name with spaces removed.
[Edit: Remove “lower case” for posterity in case someone else reads this]

These settings are not dynamic, so you must restart the server for them to take effect. If you’re running in a cluster, you must either shut down every node in the cluster at the same time, or shut down every node in the cluster bar one, disable clustering on that node, and re-enable it again.

HTH,

Greg

i have trieid the above solution but it’s not working.
I have tried cache.components.size

My bad; it’s the same case as the cache name - so in your case cache.Components.size

Greg

no, it’s not working.

Working fine for me.

Form the System Properties page;

And from the Cache summary page;

image

123456789 / 1024 / 1024 = 117.74

can you tell the openfire version you are using. I am trying this with openfiee 4.4.1 and it seems like not working for me.

This was with 4.5.0.

Greg

yes. tried with 4.5.0 and it seems like workin.
thanks :smiley: