powered by Jive Software

iChat 4.07 Video support

Does anyone know if I should be able to do video with iChat 4.07 and Openfire 3.63?

If I click on another user, video/screen sharing/voice is initially available, then when we try to accept the session invite it errors and sends a notification to Apple.

TIA

Ze Stuart

Absolutely. Video works great. The video sessions happen independently of the OpenFire server. OpenFire just makes it so that each client can reach the other.

Interesting, are you running on the default OpenFire config? Any extra plugins to make this work?

Also, what version of OS X do you have? 10.5.6 here…

No plug-ins needed. Using OpenFire as the server is no differerent than using AIM on iChat.

Thanks Ryan.

If anyone else reads this and is interested, my connection log is below:

2009-02-24 13:35:45 +0000: AVChat started with ID 2565198087.
2009-02-24 13:35:45 +0000: 0x29e53f80: State change from AVChatNoState to AVChatStateWaiting.
2009-02-24 13:35:45 +0000: user@domain.local2: State change from AVChatNoState to AVChatStateInvited.
2009-02-24 13:35:50 +0000: 0x29e53f80: State change from AVChatStateWaiting to AVChatStateConnecting.
2009-02-24 13:35:50 +0000: user@domain.local2: State change from AVChatStateInvited to AVChatStateConnecting.
2009-02-24 13:36:01 +0000: 0x29e53f80: State change from AVChatStateConnecting to AVChatStateEnded.
2009-02-24 13:36:01 +0000: 0x29e53f80: Error -8 (Did not receive a response from 0x29e53f80.)
2009-02-24 13:36:01 +0000: user@domain.local2: State change from AVChatStateConnecting to AVChatStateEnded.
2009-02-24 13:36:01 +0000: user@domain.local2: Error -8 (Did not receive a response from 0x29e53f80.)

(This is for initiating a video chat.)

Video doesn’t necessarily work great. If both parties are connected via Jabber account to the same Openfire server, then yeah, video should indeed work—if it doesn’t, you’re probably looking at a NAT router issue, UPnP, something like that. If their buddy icon has the video button next to it, then this is probably the case.

But if you’re trying to initiate a video chat with someone who’s on another service, via the gateway plugin, video probably won’t work. The video icon won’t even appear next to their buddy icon.