powered by Jive Software

Idle User Logout

I’m having difficulty with a few users being logged out from time to time. I think it’s because their ‘heartbeat’ packets aren’t getting to the server. Is there a way to change the length of time a user must be idle before Openfire logs them out?

Hi

The property “xmpp.client.idle” sets the time in millesconds to disconnect an idle client.

I think the default has changed a few times. According to the properties page:

http://wiki.igniterealtime.org/display/WILDFIRE/Openfire+Properties

it is 30 minutes but I think it will depend upon what version of Openfire you have.

BR

David

Thanks a bunch rectorydp! I was having a terrible time locating that property. I suppose it would have been easier to find had it been one of the few properties that show up by in the ‘System Properties’ in the Server Manager section. I added it as a new property with a value of -1 (disable) and restarted Openfire.

No problems so far.

Hi

Happy to help. I understand what you mean about finding the properities. That was why I posted the link. There are many different (and useful) properties and without that summary it is difficult to find what you want.

If the change to the timeout works, you may want to think about setting it to a real value - just to make sure that stale sessions get killed off.

BR

David

I’m not really concerned about it. I have a small fixed number of users. Because of all the firewalls and VLANs a couple of them were getting kicked off a few times a day. If it surfaces as a problem I’ll change it then.

Thanks again!