powered by Jive Software

IllegalArgument

Hi all.

Sorry if this is repost.

a plugin of mine in wildfire server uses classes from some other package.However I am getting an interface invisible error.All other classes in that package are not only visible but are loaded and executing too.

The package I am using is built using java 1.4 and all internal calls it makes to other

jars are also built using 1.4

java.lang.IllegalArgumentException: interface com.untd.conf.common.interfaces.IConferenceTrigger is not visible from class loader

at java.lang.reflect.Proxy.getProxyClass(Proxy.java:353)

at java.lang.reflect.Proxy.newProxyInstance(Proxy.java:581)

at NSREGas.a(DashoA14292)

at NSREGh.create(DashoA14292)

at NSREGh.create(DashoA14292)

at com.untd.conf.client.app.ConferenceTrigger.(ConferenceTrigger.java:76)

at com.untd.conf.client.control.ConferenceControllerImpl.playAnnouncement(Conferen ceControllerImpl.java:50)

at com.uol.ExamplePlugin.processPacket(ExamplePlugin.java:141)

at org.jivesoftware.wildfire.component.InternalComponentManager$RoutableComponent. process(InternalComponentManager.java:347)

at org.jivesoftware.wildfire.MessageRouter.route(MessageRouter.java:90)

at org.jivesoftware.wildfire.PacketRouter.route(PacketRouter.java:69)

at org.jivesoftware.wildfire.net.SocketReader.processMessage(SocketReader.java:491 )

at org.jivesoftware.wildfire.net.ClientSocketReader.processMessage(ClientSocketRea der.java:62)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:196)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Thread.java:595)

Is that version problem or something else is happening here?any help or pointer is badly needed…