IM Gateway Plugin not working in Windows 2003 SBS Premium

I wonder if someone out there had the same problem and eventually found a fix.

I have Openfire 3.5.2 with IM Gateway 1.2.3 installed on a SBS 2003 Premium with ISA Server 2004.

All works fine but the plugin is unable to connect to any service. The plugin does not allow for choosing which of the Network adapters it will use to connect, so it goes default to the WAN adapter, where I have absolutely no filter or anything of the sort. The traffic should simply go through but it does not. After s while all I can get is a failure when I test the connection and that’s it.

Hope someone has ideas on how to enable IM Gateway to work with SBS 2003 & ISA 2004.



I have the same problem with Openfire 3.5.2 on FC 6 with mysql 5. Is the plugin working for anyone?

Thanks for any info,

My friend, in my case, it works just fine when Openfire is NOT installed on the computer hosting ISA Server. Unfortunately, in my case, for most of my customers this is not a possibility as SBS 2003 runs on a single server and ISA Server is one of the components.

In this situation, it seems the plugin does not try to connect to the Internet through the INTERNAL NIC, but the External. I can’t see it’s traffic going through the firewall at all. There’s no filtering on the External NIC but even so, there’s no connection. I tried to create a rule in ISA Server allowing traffic from port 1863 (for MSN) from the Internet to the internal NIC of the server but still no connection…

My experience is that openfire uses what NIC is the primary at boot for all processes. If openfire cannot connect to a gateway then I would suspect your ISA server is not properly configured to allow this function. Is the ISA server used for other services or can you disable it all together (do you have another firewall)?