powered by Jive Software

I''m having an issue with external authentication and groups

Greetings;

I’‘ve configured OpenFire to utilize a separate authentication database that I’‘ve created that syncs up with my forums software. Everything works to a point. All of my users can authenticate, and when I go into the admin interface and view the user list I see everybody who’‘s registered. I also see all of my groups and they have all of the appropriate users in them however when I log in, I don’‘t show as being ‘‘online’’ in the group. If I go to back to the admin interface and view the user list it shows me as being online in the user list but when I view the group list from the admin panel I don’'t show up as online there. On the client side I can see myself in the search list and group list but I show up as offline.

I have manually run each of the queries I have defined and they all return the proper information so I’'m not sure what else to look at there.

The following is my setup (and I am aware that I user the username field for both the login username and the ‘‘name’’ field, this is intentional, also I do have the & in the connection string as & amp ; it’‘s just translated to an & because, well, it’'s an HTML entity):

This may be unrelated but I keep seeing this in my error.log after I’'ve connected:

2007.04.17 20:46:19 org.jivesoftware.openfire.session.OutgoingServerSession.createOutgoingSession(Ou tgoingServerSession.java:258) Error trying to connect to remote server: solodrakban(DNS lookup: solodrakban:5269)

java.net.UnknownHostException: solodrakban

at java.net.PlainSocketImpl.connect(Unknown Source)

at java.net.SocksSocketImpl.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at org.jivesoftware.openfire.session.OutgoingServerSession.createOutgoingSession(O utgoingServerSession.java:253)

at org.jivesoftware.openfire.session.OutgoingServerSession.authenticateDomain(Outg oingServerSession.java:142)

at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.sendPa cket(OutgoingSessionPromise.java:199)

at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.run(Ou tgoingSessionPromise.java:184)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Help?

Sorry, I forgot some additional information:

OpenFire version is 3.3.0 and it’'s a MySQL 5.0 database using the built in JDBC connector.

Message was edited by: Solo Drakban

Message was edited by: Solo Drakban

An addendum - When I click on the username in the session lists and view the user profile, the user shows up as not belonging to any groups.

Did you even find a solution to your problem? I seem to be having the same issue, as detailed here:

http://www.igniterealtime.org/forum/thread.jspa?messageID=147888&#147888