powered by Jive Software

I'm missing something, somewhere

I have OpenFire and Spark installed on a server on an internal network. It is behind a firewall, but most IM ports are open. A few of us are using Spark but a larger number are using other services, most notably AIM MSN and Yahoo. I installed the IM gateway plugin. My problem is I cannot figure out how to allow outside users to contact our server, and on the reverse, Spark users to contact outside users. How do I properly ‘register’ outside users so they can become available on the contact list? When I ‘test’ the connection in the admin screen, it is successful. This seems to be an area where some proper documentation would be very useful

If the test went ok with the gateway plugin for the protocol that you want to use, then you need only configure the appropriate gateway account on the spark client for that user (generally). Then you sign in that gateway account and their entire buddy list will come with it (ideally). See my picture for a little visual guidance.

I am hoping you might be able to elaberate on your answer. I have a similar configuration everything with openfire and spark works perfect on my LAN. My problem comes when dealing with external users on yahoo. I have it enabled and it tests successful and all but when I go and add the yahoo user to my roster it just sits in a pending state and the user never gets my request. My firewall is configured to allow all outgoing connections and I have following errors in my debug log.

2007.12.05 16:04:52 Received iq packet: <iq id=“50i13-47” to=“icq.msw-im1” type=“get” from=“mwoolman@msw-im1/spark”><query xmlns=“http://jabber.org/protocol/disco#info”/></iq>

2007.12.05 16:04:52 icq: Sending packet: <iq type=“result” id=“50i13-47” from=“icq.msw-im1” to=“mwoolman@msw-im1/spark”><query xmlns=“http://jabber.org/protocol/disco#info”><identity category=“gateway” type=“icq” name=“ICQ Transport”/><feature var=“http://jabber.org/protocol/disco#info”/><feature var=“http://jabber.org/protocol/disco#items”/><feature var=“jabber:iq:gateway”/><feature var=“jabber:iq:register”/><feature var=“jabber:iq:version”/><feature var=“vcard-temp”/></query></iq>

2007.12.05 16:04:52 Received iq packet: <iq id=“50i13-48” to=“yahoo.msw-im1” type=“get” from=“mwoolman@msw-im1/spark”><query xmlns=“http://jabber.org/protocol/disco#info”/></iq>

2007.12.05 16:04:52 yahoo: Sending packet: <iq type=“result” id=“50i13-48” from=“yahoo.msw-im1” to=“mwoolman@msw-im1/spark”><query xmlns=“http://jabber.org/protocol/disco#info”><identity category=“gateway” type=“yahoo” name=“Yahoo! Transport”/><feature var=“http://jabber.org/protocol/disco#info”/><feature var=“http://jabber.org/protocol/disco#items”/><feature var=“jabber:iq:gateway”/><feature var=“jabber:iq:register”/><feature var=“jabber:iq:version”/><feature var=“vcard-temp”/></query></iq>

2007.12.05 16:05:07 OS - Trying to connect to yahoo.com:5269(DNS lookup: yahoo.com:5269)

2007.12.05 16:05:27 Error sending packet to remote server:

Any ideas?

mwoolman wrote:

I have it enabled and it tests successful and all but when I go and add the yahoo user to my roster it just sits in a pending state and the user never gets my request.

Just to make sure. Have you signed in with your Yahoo account before adding any new yahoo contacts? Can you chat with your old yahoo contacts after you have signed in?

Also, the way to add a yahoo contact is not by adding john@yahoo.com but instead do it through the gateway plugin. If you are using Spark then make sure that you are checking that the contact belongs to yahoo.

Regards,

– Gato