powered by Jive Software

IM session conversion to group chat

I’'m trying to rollout wildfire at my company, and one piece of feedback I have recieved is the seeming lack of the ability to do the following as compared to say MSN:

Two people are having an IM session, they realize a third person should be included, they can then immediately invite that person to the current conversation.

From what I can see in the case of wildfire they would have to join a chatroom and invite participants to join. It works but is not as seamless, and the conversation history is lost unless someone cuts/pastes it into the chat room.

Is this correct, would it be possible to add this functionality (direct conversion of an IM conversation to a chat conversation) to a future version if it is not?

Thanks,

chrisla23

I think that’‘s msn feature only. I don’'t think yahoo or google has it. I think it has more to do with the jabber protocol then WildFire. I might be wrong.

Regards,

Wmhtet

There are provisions in the JEPs to turn a one-to-one into a conference. Its actually up to the client to do the heavy lifting. Spark has support for this via the conference button.

Thanks,

Alex

Great, except something is broken or really non-intuitive.

I’‘m running Wildfire 2.5.1 on RHEL 4/1.5.06 and Spark 1.1.3 on Windows. I start an IM with someone, and sure enough the conference button is in the top middle of the session. When I click on it, a whole lotta nothing happens. I’'ve tried right-clicking, highlighting a name and then clicking, etc. My boss also tried everything he could think of independently, and also came up empty handed.

Am I missing something or is it broken?

Thanks!

Hey Chrisla23:

It appears to be functioning correctly though no feedback is given to the user that you have invited others to the conference. I have created an issue: SPARK-251

Thanks,

Alex

I’‘m not sure I follow that it is functioning correctly for me, or I don’'t understand what the expected behavior is.

  • I’'m talking with someone

  • I hit the conference button

  • Nothing happens

  • I’'m still just talking to them

I don’'t see how I am in a conference, or a means of inviting anyone else to it in this context. What steps am I supposed to follow to convert an im session with one person to a conference with 2+ and keep the past conversation history in the conf.

Thanks, I appreciate your assistance, and opening of a bug.

Thats intresting. What happens for me after I press the button is I get a dialog on who else I would like to invite to the conference. I can then select them from a list and they are invited. Do you see any errors in your Spark error logs?

I have a couple of errors (I stopped spark, deleted the log, restarted) but none of them are new as of trying to press the conference button.

More about the environement:

Microsoft Windows Server Standard Edition 2003 (me) or Windows XP Pro (boss)

I am connecting via terminal services, though my boss is directly on his laptop. Both the profile and send file buttons work fine.

Spark 1.1.3 Offline Edition

Thanks.

Mar 17, 2006 1:06:34 PM com.jivesoftware.spark.util.log.Logger logError

SEVERE: Unable to contact shared group info.

No response from the server.:

at org.jivesoftware.smackx.SharedGroupManager.getSharedGroups(SharedGroupManager.j ava:46)

at com.jivesoftware.spark.ui.ContactList$17.construct(ContactList.java:1196)

at com.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:121)

at java.lang.Thread.run(Unknown Source)

Mar 17, 2006 1:06:34 PM com.jivesoftware.spark.util.log.Logger logError

SEVERE: Unable to load private data for bookmarks.

No response from the server.:

at org.jivesoftware.smackx.PrivateDataManager.getPrivateData(PrivateDataManager.ja va:194)

at com.jivesoftware.spark.ui.conferences.Conferences$3.construct(Conferences.java: 162)

at com.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:121)

at java.lang.Thread.run(Unknown Source)

Mar 17, 2006 1:06:34 PM com.jivesoftware.spark.util.log.Logger logError

SEVERE: Unable to load search services.

No response from the server.:

at org.jivesoftware.smackx.ServiceDiscoveryManager.discoverItems(ServiceDiscoveryM anager.java:404)

at org.jivesoftware.smackx.ServiceDiscoveryManager.discoverItems(ServiceDiscoveryM anager.java:373)

at org.jivesoftware.smackx.search.UserSearchManager.getSearchServices(UserSearchMa nager.java:93)

at com.jivesoftware.sparkimpl.search.users.UserSearchService.loadSearchServices(Us erSearchService.java:94)

at com.jivesoftware.sparkimpl.search.users.UserSearchService.(CheckUpdates.java:91 )

at com.jivesoftware.MainWindow.checkUpdate(MainWindow.java:447)

at com.jivesoftware.MainWindow.access$200(MainWindow.java:54)

at com.jivesoftware.MainWindow$8.run(MainWindow.java:375)

at java.util.TimerThread.mainLoop(Unknown Source)

at java.util.TimerThread.run(Unknown Source)

Hi Chris,

It looks like the server name is different than what you are logging into. Could you specify the server domain as well as what are you using to log into it?

Thanks,

Derek

Server hostname, as outputted by hostname: A.COMPANY.COM

Server Name: B.COMPANY.internal

Server Ports

1: IP:Port, Security: 10.x.x.x:5269, NORMAL

Domain Name(s): B.COMPANY.internal

The B.COMPANY.internal is a CNAME to A.COMPANY.COM. Reverse lookup would go to the B address.

Group chat service name: conference

In the spark login window:

Username: myuser

Password: mypassword

Server: B.COMPANY.internal

I have verified that this also happens on my test server that is not a cname, and the reverse and forward DNS entries match what I am putting into sparc. This conference button just never does anything.

Any ideas what I can do?

Thanks.

Ok, I’'ve narrowed it down further on my own. The problem only shows up when I am pulling accounts and groups from AD:

I also noted that when AD is enabled when I click on the “conference” tab on the bottom of the spark window correctly shows conference.hostname.subdomain whereas when LDAP is enabled it is blank. When I add it, it’‘s gone again the next session, and the conf button in an IM is still broken. Otherwise AD is working for login, groups, shared rosters etc. I can manually join conference rooms fine. I just can’‘t seem to create one on the fly. Could it be that I don’'t have write access when LDAP is enabled?

Can anyone with AD confirm if this works for you, if so could you send me your conf file?

Thanks!