Import XML file ordering problem?

I am trying to migrate from a jabberd 1.4 server to Wildfire 3.1.1 and am running into problems with the user import plugin.

I hacked a bit on the migration script from and got what I thought was a good import file. Trying to load it generated a “The import file does not match the user schema.” error. I trimmed the file down to a single user and tried to load that, but no luck. I then exported the existing uesrs (all 1 of them) and used copied the user’'s data into that XML framework. THAT worked.

Some more poking around indicates that changing the order of ANY of the elements in the

Someone please tell me I’'m doing something wrong and point me in the right direction.

System info:

Fedore Core Linux

Wildfire 3.1.1 (from RPM on site)

Import/Export Plugin 2.0.4

Hi Lance,

You’‘re right, the element order shouldn’‘t make a difference. After small tweak to “wildfire-user-schema.xsd.xml” file I was able to import your example (with the username and password elements swapped) without any trouble. If you’'d like I can send to a patched version of the plugin for you to try out. Let me know.



Yes, please do send me the patched version to try out. Migrating my user data is a deal-breaker for getting from jabberd to wildfire.



Hi Ryan,

I tried the version of the userimportexport.jar you sent me and it appears to work. I was able to import the users file I generated with my script without error.

I was able to get wildfire up and running with my imported user data.

Glad to hear it. I’'ll check the changes into subversion and ask that an updated version be posted.