powered by Jive Software

In admin console Security Settings, cannot set TLS to Optional

Hi,

I am using Openfire 3.6.4. I believe the following is a bug. In the admin console, Server Settings -> Security Settings, under Server Connection Security select “Custom”, and then select TLS Method to Optional. Then click Save Settings. It will say settings have been saved, but instead of “Custom” security, “Optional” or “Required” is selected. If TLS Method is instead set to Not Available, then the Save Settings works.

Strangely, if Server Dialback is set to Not Available, then “Required” is selected after the save; if it is set to Available, then “Optional” is selected.

At first i thought this is a bug too. But it just switches to the appropriate profile if custom settings match this. If you select Optional and Save that and then go to Custom you will see that Dialback is Available and TLS is Optional. These are the settings that you have saved, Optional settings. So, if you dont change that and hit save it will check Optional, because it is the same, you havent changed it to something custom. And Dialback - N/A and TLS Optional are the settings of Required, so it will switch to Required if you try to save Custom settings like that. The only settings which can be saved as Custom are Dialback -N/A, TLS - N/A and Dialback - Available, TLS - N/A.

wroot, thanks for the response. That makes sense.

However, this is quite confusing for a new user. I was merely following this screen shot in Google’s instructions for setting up Google Wave with Openfire (http://code.google.com/p/wave-protocol/wiki/Installation). It was surprising to see those settings seemingly not being saved.

I agree that this is confusing, and Google was probably confused too. They should just instruct to select Optional without going to the custom settings.