Inconsistant Contact Lists (LDAP)

I have an Openfire 3.10.2 server and about 45 Spark 2.7.2 clients. We use LDAP. All client computers are Win7 Pro 64. My problem is that the contact lists on one of these clients is different from the rest. For example, all the Spark lists except one have names listed as “Firstname Lastname”; but the one exception has some names in the list in a format that matches the AD user account name “f.lastname”. We also have users grouped into two groups by office. Recently I needed to re-name one of these offices. In all the Spark lists except one, the contacts appear properly under an office group. But in the one exception, there are three groups: The unchanged office, the re-named office, and the old name of the re-named office. (So groups A and B became A and C for 44 Spark users, but the 45th Spark user now has groups A, B, and C with the same contact names duplicated under B and C)

I have tried changing Preferences->Appearance->“Specify reconnection display” from “Display as Panel” to “Display in contact group” because this fixes an occasional problem we get with duplicate contacts in the list, but this did not fix the problems mentioned above.

I have also un-installed and re-installed Spark, cleared Openfire’s caches, and manually removed %AppData%/Roaming/Spark and re-connected. None of these efforts made any change in the list.

Ideas anyone? Where does Spark keep it’s “local copy” of the contact list and how can I force a refresh?

Thanks in advance!

I believe this is an Openfire issue (with LDAP integration), so i have moved this thread to Openfire Support and also added “LDAP” to the title, so LDAP versed users would see this and maybe suggest something. Spark is not saving shared rosters locally.

so, let me get this right…only 1 user is having the problem? If so, what happens when the user having the problem signs in from a different workstation? Did you restart openfire after clearing the cache?

Yes, only one user has this problem. That user happens to be the only user set up as an administrator in Openfire, but other than that the installations are identical to the other 44 users. I did restart openfire after clearing the cache by rebooting the server.

I tried logging in the problem account from another computer and the same thing happened – mix of name styles in the contact list and three groups instead of two. I also connected to Openfire from an Android app called Xabber (XMPP client) and had the same symptoms there as well.

So am I looking for something in Openfire permissions or Active Directory groups? Because we’re using AD there is not too much to set on a per-user basis in Openfire, but Administrator status is one difference.

Try this:

  1. Have the user log out completely from client.
  2. Log into the admin console
  3. Navigate to Users/Groups
  4. Find the user and open up their Roster
  5. Change Show to ‘No shared groups’
  6. Delete anything in there. You will have to set show back after every one.
  7. Have them log back in.

If something shows a Lock on it then you can’t get rid of the changes made quite so easily. For those ones have to be sure to remove them from all groups and make sure nothing should show up in their roster. Then it should let you remove those ones.

From what I have noticed there are shared items handled by group configuration and then there are the user’s individual roster items. This lets users add their own custom groups and users for each. It can also be used to set custom nicknames for users from shared group. Those are the ones that can cause problems when you update or change groups around. The user’s individual roster changes will take priority over the shared group.

Thank you Frank!

I did have locks on most user names in the roster. I needed to stop sharing groups for both groups, and then I was able to delete all the users. I logged back in to Spark and… Empty contact list! So I went back to Openfire, set up group sharing the way it was before I disabled sharing. Then I tried logging in to Spark again and the contact list appeared the way it should. Thank you all very much for taking the time to answer.