powered by Jive Software

Increase java memory (using debian package)

Hi all,

I’m using openfire 3.4.4 debian package and trying to increase java version on /etc/default/openfire with:

DAEMON_OPTS="-Xms256m -Xmx389m"

With this option my openfire server running with:

dfbsadmz19:~# ps ax | grep -i openfire

16898 ? Ssl 0:35 /usr/lib/jvm/java-1.5.0-sun/bin/java -server -DopenfireHome=/usr/share/openfire -Dopenfire.lib.dir=/usr/share/openfire/lib -classpath /usr/share/openfire/lib/startup.jar -jar /usr/share/openfire/lib/startup.jar -Xms256m -Xmx389m

But in Console Admin I see this value:

44,15 MB of 81,25 MB (54,3%) used.

How to fix this?

Att,

Fernando Ribeiro

Try editing the init script and adding those options to the beginning of DAEMON_OPTS … lets see if that makes a difference.

Fixed.

Patch attached.

Thanks.

Excellent, that fix will be in 3.5.0. Thanks!

Actually, I’ll get it into 3.4.5. I’m considering this a “QA catch” thanks!

Thanks!

Excellent work!

This is what I was looking for… but (i´m sorry for been such an ignorant ?:expressionless: ) how do I apply the patch?

Thank you!