powered by Jive Software

Initial Installation LDAP and AD Issue

I have just loaded Openfire 3.8.1 on a RHEL server - no issues. Started openfire - no issues. I use the web interface to configure openfire, and that is where I run into problems, getting Openfire to talk to my AD.

Let me preface by saying, the “test” button does not work. I’ve loaded Firefox, Chrome, IE - only save settings works, so it is very difficult to test. I have to go to the end where I add an admin, before I know if it will fail.

My set up is very vanilla. AD is city.company.com. I’ve tried Administrator and openfire users as admin. For this example, I’ll use CN=Administrator,CN=Users,DC=city,DC=company,DC=com. The server is dc1.company.com. Here’s what I put:

LDAP Server
Server Type: Active Directory
Host: dc1.company.com Port: 389
Base DN: DC=city,DC=company,DC=com

Authentication:
Administrator DN: CN=Administrator,CN=Users,DC=city,DC=company,DC=com
Password: password

But it does not work. When I get to add admins, it fails.

Any ideas?

Change your base DN to DC=company,DC=com

No, that cannot be it. There’s no domain of “company.com” in the directory. The topmost domain is “city.company.com” But, I tried it as anyway - still no good. Any other ideas?

Is there an installation directory, or an “uninstall” method for Openfire on RHEL? There are only two users, currently (it was in beta,) so I figure maybe I can just do a clean install.

than your base dn will be dc=city,dc=company,dc=com

for your ldap lookup account (admin dn) just use username@city.company.com

Thank you, speedy, David! It works!