powered by Jive Software

Install problem, can send messages, can''t receive (error 504)

Okay, I’‘ve got a jabber server up and running, but I can’‘t seem to communicate with other jabber servers. I’'ve got ports 522, 5223, and 5269 open on my firewall and they work fine.

S2S is enabled on port 5269, my domain resolves, my ports are open. Both accounts seem valid, the one i setup on my own server allows me to send messages to myself. The other account is on jabber.org.

I don’'t have any certificate other than the one that came with wildfire. SSl is set to optional.

Can anyone suggest anything I’‘ve missed? Here is a sample from my debug logs, sorry they don’'t seem to format right.

Message was edited by:

RyanFelder

.

.

.

.

.

.

2006.01.25 18:04:23 OS - Trying to connect to jabber.org:5269

2006.01.25 18:04:53 OS - Plain connection to jabber.org:5269 successful

2006.01.25 18:04:53 OS - Error,

java.lang.Exception: Failed to create connection to remote server

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.createSessionAndSendPac ket(OutgoingSessionPromise.java:139)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.access$300(OutgoingSess ionPromise.java:37)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$1$1.run(OutgoingSession Promise.java:91)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

2006.01.25 18:05:44 Finishing Outgoing Server Reader. No session to close.

java.net.SocketException: socket closed

at java.net.SocketInputStream.socketRead0(Native Method)

at java.net.SocketInputStream.read(Unknown Source)

at sun.nio.cs.StreamDecoder$CharsetSD.readBytes(Unknown Source)

at sun.nio.cs.StreamDecoder$CharsetSD.implRead(Unknown Source)

at sun.nio.cs.StreamDecoder.read(Unknown Source)

at java.io.InputStreamReader.read(Unknown Source)

at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:2971)

at org.xmlpull.mxp1.MXParser.more(MXParser.java:3025)

at org.jivesoftware.wildfire.net.MXParser.nextImpl(MXParser.java:75)

at org.xmlpull.mxp1.MXParser.nextToken(MXParser.java:1100)

at org.dom4j.io.XMPPPacketReader.parseDocument(XMPPPacketReader.java:290)

at org.jivesoftware.wildfire.server.OutgoingServerSocketReader$1.run(OutgoingServe rSocketReader.java:91)

Okay, this is a new development, I can send messages FROM my own server to my account i just set up on jabber.org

but I cannot send messages back from my jabber.org account to my account on my home server. I get error 504.

Anyone seen this??

The error 504 means that the server was not able to contact the requested remote server. So if you are sending a message from a jabber.org account to an account in your Wildfire server then jabber.org is reporting that he is not able to contact your server.

When I was testing s2s with jabber.org I remember getting that error but the reason was that my Wildfire server was down so jabber.org returned a 504 error. And even after starting Wildfire I was getting the 504 error. After waiting some time the cached error in jabber.org was removed and when I tried again it worked fine. If your server was up and running all the time then I would recommend checking that your host and port 5269 is accessible from the internet.

Feel free to post the new debugged information so we can see what’'s going on.

Regards,

– Gato

I’'ve verified that my domain resolves correctly and that the port is indeed open.

I’'m using Gaim as the client for both the jabber server on my own machine and jabber.org.

Again, I can send from my own server TO jabber.org, but not vice versa, i get error 504.

After about half an hour, it takes a minute to get a 504, so it seems it is trying again fresh.

Any settings I might have missed? I don’'t see anything happening in my logs.

I’'m also curious about getting file transfers and voice chat working between google talk, is there somewhere I can see the status of how thats working? It seems jabber.org and gmail.com users cannot do voice, and my initial try to send a file failed as well.