powered by Jive Software

Install problem - cannot access setup admin on 9090 on VPS

Having trouble setting up a wildfire install on a VPS. After starting the service, attempting to logon into the setup admin panel via http://domain.name:9090 returning a "server not found " error.

Changing domain.name to the ip of the root web service on the VPS does not help nor does selecting any domain running on the VPS. I have run nmap on the server and 9090 is open.

permissions seem fine… no error messages in /wildfire/logs and none in my local httpd error logs either. I’'m baffled at this point.

Any suggestions?

Hi there,

Do not try to connect to the admin console like http://your-domain-name.com:9090.

Try to connect via the IP-Adress of your VPS, like http://80.237.128.168:9090

Thanks for the response but yes, I tried that early on. I used the ip address of the web server root which is the ip address for any of the individual domains in question. Still get the same error message however. I also tried the domain that seems to be default for the vps and resolves if you hit the webserver ip.

e.g. http://domain.com:9090 and still get the same error…I’‘m sure it’‘s a pathing or permissions issue but can’‘t seem to sort this one out. I have wildfire running quite successfully on my test server with multiple domains but then again, it’'s not a vps so I suspect that is a part of the puzzle.

Hi,

does Wildfire starts up fine? You should see “Admin console listening at: …” in logs/info.log?

Do you see errors in bin/nohup.out ?

Does “netstat -an|grep 9090” returns a “.:9090 LISTEN” line?

Do you (or your VPS provider) use a firewall to allow only SSH and HTTP port 80/443 traffic?

LG

Netstat output

netstat -an | grep 9090

tcp 0 0 0.0.0.0:9090 0.0.0.0:* LISTEN

Nmap output

nmap -sS localhost | grep 9090

9090/tcp open zeus-admin

Wildfire starts

"Starting wildfire

nohup: appending output to `nohup.out’’ "

Although when stopping wildfire, I have to manually kill the java processes. If I do not, restarting wildfire produces some errors on nohup

Admin Console

Admin console is listening at localhost (http://127.0.0.1:9090)

When I run bin/wildfire status I get the error message

Error occurred during initialization of VM

Could not reserve enough space for object heap

Could not create the Java virtual machine.

Although I have Java processes running after I start Wildfire, I’‘m beginning to think it’'s a problem with the JRE.

I have tried killing all processes and reinstalling with the same results.

VPS is running Fedora Core 2 - Kernel version 2.4.20-021stab028.17.777-smp

Hi,

as soon as you get

netstat -an | grep 9090
tcp 0 0 0.0.0.0:9090 0.0.0.0:* LISTEN

Wildfire should be running fine. Try

wget -O - 127.0.0.1:9090

on your server to fetch the initial setup page. This should work fine and if it does you may try to run

iptables -L

and verify if you are running a local firewall which allows only traffic to :22, :80 and :443, looking like

ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:80
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:443

I guess that this is the case, so you could either open the firewall or use SSH/portforwarding to connect to 127.0.0.1:9090.

LG