Installation problem

Ok I have the following installed on a linux box also running an IP PBX on it.

Open FIre 3.7.0

Asterisk-IM 1.4.0

FastPath Service 4.2.0

Search 1.5.1

Subscription 1.2.2

I am using the embeded DB

All is working wonderfully. I have precence indicators and have gotten it working on computers off our internal net work and love all the features we have been using.

My problem is FastPath Webchat

I click on the plugins button and click on the + next to the webchat plugin and it works for a while then says it is installed successfully.

Then when I go back to the plugin page it is not listed. Then I refresh and it shows up (YEAH) It has created a folder in my plugin directory called webchat and it is full of files (YEAH) however when I go to [myipaddress]:9090/webchat I get


Problem accessing /webchat. Reason:

Not Found

Powered by Jetty://

OK so let’s try it again. I uninstall the plugin however it isn’t listed in the available plugins!?!?!? I have to SSH into my box and delete the .war file and the empty directory /webchat/ OK now the plug in is listed in the available plugin list. (YEAH) I again install. It again says success (YEAH) I go back to the plug in page and wait. It doesn’t show up. I refresh. Nothing. I check my plugin directory all the files are there. ?!?!?! I go to myipaddress]:9090/webchat and get that 404 again (GRRR) I go back to the available plugins page and it is listed ?!?! however there is no green + next to the info ?!?!?!

I have tried multiple .war files from various places on the forum here and nothing seems to work. I have tried installing the .war on another server (our website) but still can’t get the installation to come up. What am I doing wrong?

Also tried

However when I go to [myip]:7070 I get

Error 404 - Not Found.

No context on this server matched or handled this request.

Contexts known to this server are:

  • /http-bind —> ContextHandler@d1f0ad@d1f0ad/http-bind,null
  • / —> ContextHandler@1f2f60d@1f2f60d/,null
  • /webchat —> WebAppContext@1840407@1840407/webchat,null,/opt/openfire/plugins/webchat [stopped]
  • /webchat —> WebAppContext@24892b@24892b/webchat,null,/opt/openfire/plugins/webchat [stopped]
  • /webchat —> WebAppContext@a987f9@a987f9/webchat,null,/opt/openfire/plugins/webchat [stopped]

I really have tried about everything I know how to do. Please help.

Had the exact same problem.

Download webchat.war from, delete your existing webchat folder and webchat.war (restart openfire for good mesure) and upload this one.

Worked for me =]

I had tried that before and it didn’t work but this time it did so I’m not asking questions. Thank you.

For me it worked on the third try. Don’t know how or why it didn’t work the first two times, but as long as it works now, I’m happy =]