powered by Jive Software

Installed FastPath + WebChat but no workgroups show up

I installed the Fastpath plugin for OpenFire and then installed the webchat enterprise plugin. I created a workgroup with people in it and one of them is logged in. The settings show that it’s open and there is a default queue. But when I go to the http://server:9090/webchat it shows no workgroups under the “Click on one of the following workgroups to join.”

Is there some setting that I might have missed?

Thanks,

Nathan

Hey Nathan,

When you run the setup of the webchat application make sure to specify the correct XMPP domain. I guess that could be the reason for the problem you are seeing. Remember that you can use the xml debugger plugin to monitor the server traffic.

Regards,

– Gato

The problem is that the webchat client does not check SRV records. For me it worked just fine when xmpp.domain was set to “jabber.example.org”, but when set to “example.org” and xmpp.fqdn to “jabber.example.org”, the webchat plugin fails to work.

If you set the server host to “example.org”, it can’t connect (well, it tries connecting to the IP address of “example.org”, which does not host an XMPP server, so it fails.)

If you set it to “jabber.example.org” the webchat setup finishes OK, but does not show available queues, and the following shows in the logs:

2008.08.04 15:07:12 Closing session due to incorrect hostname in stream header. Host: jabber.example.org. Connection: org.jivesoftware.openfire.net.SocketConnection@b4ee66 socket: Socket[addr=/xx.xx.xx.xx,port=39285,localport=5269] session: null

Is there a workaround that I’m not aware of? I’m just looking at the SparkWeb source, will post if I find anything useful. Moving the “example.org” website to the server hosting openfire is not an option

EDIT: I tried changing XMPPConnection(xmppConfig) to XMPPConnection(domain) in setup-index.jsp, which should check for SRV records, but it still does not work. Is restarting Openfire enough after changes to jsp files or do I have to do anything else? I also changed test-connection.jsp in a similar way.

I configured fastpath webchat and it shows now workgroup to users connect in.

How do i fix that?

You need to enter ip address instead dns domain name, then you wil be able to see the image