Installing and using sparkweb

So how would one go about installing and using sparkweb… ?

if I point it to localhost it says I am not authorized I am using openfire 3.5.2

I downloaded the tar.gz file and untarted it,but have no idea about how it works.

okay some new information if I try and login all it does is send me back to the login screen with out saying anything.

I pointed it ot the dns name instead.

still confused about how it works.

thank you

you need to have the ports you configure the sparkweb open for access from outside your network. for example port 7070 for http-bind. You also need to make sure that is enabled in the openfire admin if you use http-bind. You could post your config settings for sparkweb for us to see.

Thank you so much for your response.

Sorry about being a super newbie about this, but I have some questions.

So do you want the openfire config or do you need the sparkweb config because I could not figure out where I would configure spark web?

Also are you saying you need to have port 7070 aviable on the external ip address not localhost?

The point is that there is currently no normal documentation. Especially for new users. It seems that developers think that users should figure it out themselves. I’m not a newbie here, but i have problems to get it working. All i can find are bits of information in some threads and in one document. But it’s not enough and too scattered.

SparkWeb setup is in SparkWeb.html (you have to edit that file, find javascript part in it which looks like here:

Also, i get an error upon launching it, that i have mentioned in my thread. And mtstravel said, that he had to build SparkWeb.swf himself to get it working normally.

Now now, you give me too much credit. I merely build the additional settings file, SparkWebSkin.swf, which the software seems to want in order to work without errors.

I think the one main thing that was forgotten was that the Sparkweb files need to be on the server. I just dropped the folder in my server directory and voila! (of course I did edit the html file to reflect the server name)

If you want to see it point your browser to…>


" Code is like a beautiful woman! "

You mean a webserver or somewhere in the Openfire dir?

No it can be on any web server anywhere in the world. The config seetings point back to your openfire server as long as the ports and address you entered are available from outside your network.

Ok. So i have tried putting it in apache htdocs and it started working. Thanks.

Now if they could add the transport icons and the formatting widgets that would be nice. I put mine in the main server directory and it works just fine. Just make sure that you do edit the SparkWeb.html file to reflect the im servers address and other settings you want. I added it to my server for those people that are either not computer/XMPP savy or are too lazy to set up an external client like Spark or PSI.


I am still having an issue getting sparkweb to work.

what happens is I try to login and it just refreshes the page with out any error messages.

here is my config file

function jive_sparkweb_getConfig()
return {

server: “ivy”,
& nbsp; port: “7070”,
& nbsp; bindPath: “/http-bind/”,
connectionType : “http”,
autologin : “false”


nmap ivy

Starting Nmap 4.53 ( ) at 2008-07-28 05:54 MDT
Interesting ports on ivy
Not shown: 1699 closed ports
22/tcp open ssh
25/tcp open smtp
80/tcp open http

587/tcp open submission
2020/tcp open xinupageserver
3306/tcp open mysql
7070/tcp open realserver
8080/tcp open http-proxy
9090/tcp open zeus-admin

I fixed my own problem the issue was port 5222 was not open on my openfire server installation

after I did that everything worked just fine.

you need port 5222 to be open

Openfire could be used like a WebServer itself, just copy the sparkweb directory inside the openfire\plugins\admin\webapp directory, and then you could use Webchat from the administration port of Openfire(9090 by default). Just use http://OpenfireServerip:9090/sparkweb/SparkWeb.html, no Apache or IIS needed…