powered by Jive Software

Installing plugins from the admin console and proxy

This is my second try at getting this issue reopened/resolved. I posted the following as a comment to the Jira issue

http://www.igniterealtime.org/issues/browse/JM-752

We are using Openfire Enterprise v. 3.4.2. I have set:
update.proxy.host proxy.nyu.edu
update.proxy.port 8000
And it uses the settings if I update the list of plugins. This is verified by netstat -a output:
jive.60247 PROXY2.NYU.EDU.8000 49232 0 66608 0 ESTABLISHED
But if I try to then install a plugin by pressing the “+”, it ignores the proxy setting, as shown by netstat -a:
jive.59480 63-246-20-125.contegix.com.80 0 0 65700 0 SYN_SENT
Also, the new “Ignite Realtime News” on the main page of the console should likely also be using the proxy, but (I am guessing) doesn’t seem to be.

So the setting is working, but just for the updating of the plugin list. It seems as though any http/s connections that go out from the openfire box on port 80/443 should use the proxy setting.

EDIT: I also found http://www.igniterealtime.org/issues/browse/SPARK-225 which claims to have fixed something similar.

Message was edited by: puskar