powered by Jive Software

instantFeed (RSS-Feed plugin)

Hi,

did anybody got the instantFeed plugin running with Openfire 3.6.4 and Java 1.6? I tried the 1.0.6 binary, which actually seems to be 1.0.5. This doesn’t work…I don’t recieve feed notifications…

I also tried to build the source myself…I can’t even build it:

BUILD FAILED
/mnt/data/edit/openfire/work/openfire_instantfeeds_3_6_4/build/build.xml:1222: The following error occurred while executing this line:
/mnt/data/edit/openfire/work/openfire_instantfeeds_3_6_4/build/build.xml:1231: The following error occurred while executing this line:
/mnt/data/edit/openfire/work/openfire_instantfeeds_3_6_4/build/build.xml:1233: The following error occurred while executing this line:
/mnt/data/edit/openfire/work/openfire_instantfeeds_3_6_4/build/build.xml:1468: java.lang.NoClassDefFoundError: org/apache/xpath/XPathAPI

Google says this might have something to do with the Java version. Some guys using XPath had problems switching from Java 1.4 to 1.5. However, Openfire 3.4.0 did run with Java 1.5 (or not?)…so this is another problem here.

I also mailed to the author, but got no response yet.

Any ideas?

I really need some way to get RSS-Feeds into Jabber. At least it would make some things a lot easier. Does anybody know another plugin or external component which does the trick?

I got it compiled and running, but some NullPointExceptions are thrown during the communication with the feed bot. So I think this need some further work…

Edited: Updated with new files, project was moved to a maven project, so you have to install maven and the Openfire Maven Plugin (http://maven.reucon.com/projects/public/maven-openfire-plugin/1.0.1/) to compile. No NullPointerExceptions for me now…
instantFeeds.jar (1302028 Bytes)
instantFeeds.tar.gz (45335 Bytes)

Ok, thanks…NullPointerExceptions are a point to start searching for problems…

instantFeeds-src.tar.gz is only 45.1kb in size…and not a vaild gzip file…something wrong there

I updated the above attached files. Yes its only 45kb, I moved it to a maven project and removed the libaries (which now manages maven), so its only pure source code. The md5 sums are:

fcf2470d139ad5a63aeabe34b73716e8 instantFeeds.tar.gz

cc9c4884eab9f4e499591d2158747336 instantFeeds.jar

No NullPointerExceptions for me now…
Sounds good, I will look at it tomorrow…

Sorry there was an error, here the version which works with the current openfire trunk without problems for me.
instantFeeds.tar.gz (45330 Bytes)

Can you provide you compiled Version of instantFeed?

We didn’t get InstantFeed to run with Openfire 3.6.4. It does just throw some strange errors instead delivering the feeds you subscribed to.

I solved my problem in an other way: I wrote an plugin for WordPress which can deliver posts to Helga which delivers them to all members of one or more shared groups. I will probably publish both in a few weeks.

Hello,

I’m very interested in this plugin. Where can I find the compiled version working on openfire 3.6.4 ?