powered by Jive Software

Invalid username and password

I have installed the latest version of Openfire (3.6.4) and spark (2.5.8) and I’m utilizing the LDAP capability. After installing and setup, i can successfully login from spark and everything seems to work fine but if there is a server reboot or the openfire services have to stop and get restarted then i am not able to login into the spark client. I’m posting this in the openfire area for this reason. When the initial service window starts initially, it shows its listening on 127.0.0.1. After setup is complete it still shows the same thing. If i stop the services and then restart (to simulate a server reboot) it shows that its listening on “http://servername/port”. At that point I’m not able to login from a client. I’ve tried all sorts of setup, install and server reboot steps in different orders but can’t seem to locate the issue.

Thx

Hi,

I assume that you did use a name like “example.com” for the xmpp.domain name. Can the server resolve this name to the IP address it is using?

Run “cmd.exe” and execute there “netstat -an” - this should show that port 9090,9091 and 5222 are open, either as “0 0.0.0.0:5222” (listening on all IP addresses) or as “12.34.56.789:5222” but likely not as “127.0.0.1:5222”.

LG

I can see the ports listening when running the netstat command but it still will not allow the spark client to connect. Honestly,. I checked everything from firewalls to different settings in the setup process to different types of databases. I’m sure the product is good but so far its not worth the trouble and time that I’ve been spending with it. I’m probably gonna punt and tell our customer to go with MS Office Communicator.

Is there any paid support options that’s available for this thing?

http://www.igniterealtime.org/support/service_providers.jsp

As i pulled my last piece of hair out, i decided to try one more thing. I uninstalled the software, reinstalled it with what i thought was the correct settings and started tinkering with the firewall. I guess this time i had the correct settings entered because i found the correct combination of ports to open to allow it to work. I had been opening 9090 and 9091 but not 5222 and 5223. When that happened, it clicked. Thanks for your help.