IRC Transport Does Not Understand /me

Within IRC, people should be able to use the “/me” command to issue emotes customized to their Nick. Such as:

Client Prompt for Nick “Caine”> /me is tired.

…should return this on the IRC server.

“Caine is tired.”

And in general, the IRC transport seems to not be funcational with any IRC-type commands. i.e., anything one transmits as prefixed with a slash (which normally is the queue to tell the IRC server that whatever comes next is a command for the server, such as /topic, /away, /whois, /kick, /ban, /motd, etc. ) gets escaped and printed exactly as typed. So if one types “/me is tired.” they see simply “/me is tired.”, etc.

Can this be fixed for at least /me? This is behaviour people tend to expect from IRC, but appears to be impossibleusing the IM Gateway.


I just recently setup the gateway and some of the commands seem to work for me when connected /me and /topic worked in Adium, while just /me worked in iChat. The others did not seem to work in either client, so the client seems to have something to do with it. Hope that helps a bit.