powered by Jive Software

Is it possible to change the time the Spark popup Caller ID is visible?

calleridpopup.gif

Does anyone know how to extend the time the CallerID popup is visible in Spark?

It’s set at like 1 sec and that’s just not long enough for my staff…

Openfire 4.0

Spark 2.7.5

Asterisk-IM 1.4.1

Thanks

Lance

I don’t think its configurable. How long does it stay up? I’m guessing 5 seconds? How long would you like for it to display?

It’s only staying up about a second. It needs to be much longer… 5 seconds would be great.LOL

[SPARK-1684] Toaster Pop up for Incoming Call is too short. - Jive Software Open Source

Ive created a ticket. Unfortunately, there are no spark devs right now (know any java/xmpp guys that want to help out?), so it might be a bit before this gets fixed.

It looks like it pops up for about 5 seconds for me.

ok…that part of the code was easy enough for me to figure it out. I’ve changed the time out to 15 seconds and tested it locally. I’ve summited a PR, so this should work for you after it gets merged and should be in a nightly build soon after.

1 Like

Should be in the latest nightly build (762 for windows) Ignite Realtime: Spark Nightly Builds Will be included in 2.7.6 version (sometime in March).

Here’s the list of changes in this build (Done) SPARK: 2.7.6 - Jive Software Open Source

1 Like

Thanks Wroot,

That makes it much more useful…

Lance

Thanks Speedy…

I tested it on the nightly build, looks good.

Lance

After pushing it out to my staff, it broke something…lol

Now the status doesn’t change back from “on the phone” to blank

2016-01-25_15-26-28.gif

So these staff are actually idle but shown as on the phone.

Lance

odd, I’m not seeing that issue. After I hang up on the extension, it looks like it goes back to normal. I’ll play around with it to see if I can duplicate it. Is it only your spark showing presents incorrectly or everyone?

Everyone… it seems to be a timing issue… I’ll narrow it down as soon as I have a minute.

Lance

I tried to reproduce this but I was unable to. Let me know if youre able tor reproduce it, and what steps you took to do it.

I ended up changing the Idle time to longer than 3 minutes and it stopped happening.

I think having the idle message and “on the phone changing” so often was messing something up…

Since the change, it hasn’t happened again.

Thanks again

Lance

What was the previous setting? I guess we can still qualify this as a bug. Then a user is on the phone, auto away shouldn’t kick in.

I guess it was at 3 minutes which is the default I think.

Ah, i misread that you have changed it to 3 I have it on 10. Anything less is just too short for my taste. You can be talking to someone (face to face or on the phone and going away, when you are still at your desk).

speedy, can you confirm that with a low auto away setting?

I’ve been unable to reproduce this. I tried many different ways, and just wasn’t able to.

ok…spoke too soon. I’m able to reproduce this.

It looks like the following is happening.

Call comes in and presence gets set to “on the phone”

then, no computer activate, which triggers the idle timeout.

at this point, I’m guessing SPARKS idle timeout logic is capturing the last presence state prior to idle, which is “on the phone”.

Call ends, which resets presence.

There is computer activity, which kicks spark out of idle, and sets presences to its last captured state, which is “on the phone”.

I

now how to fix this? I have no idea. This one may need to be done by a pro!

There is a patch proposed in the comments here [SPARK-1455] Spark is getting stuck with “On Phone” status after unlocking Windows - Jive Software Open Source But it is hard to find the right place for some of the parts (the code has evolved).

I looked at that patch, and tried to implement it, but I think its trying to hard to solve the problem. I have an idea for a simple approach that might work…although simple for a a guy likes me, means hours of googling!

I think all we have to do is tell the idle plugin to ignore a presence of “on the phone”, or only set for presence types “chat or online”? anyway…that should be easy enough, right? lol