Is WildFire ServerToServer with TLS/SSL supposed to work in 3.0.0?


I’‘ve been using WildFire 2.6.2 on RHEL4 for a couple of weeks and really like it. I tried to get ServerToServer going with TLS/SSL and was unsucessfull. It gives SSL errors. I saw that 3.0.0 came out a couple of days ago and so I upgraded my two servers today. I just tried TLS/SSL again and it didn’‘t work. I turned off Required Security between servers and now they can communicate again, leading me to believe that ServerToServer via TLS/SSL still doesn’'t work. Is this correct? If not, can someone point me to some docs to get it working?


Could you post the errors you are seeing in the error logs? That would likely help in diagnosing the issue.



Hey David,

Note that by default Wildfire will verify certificates and if certificates are not trusted then TLS cannot proceed. If this is a simple test then you can disable certificate verification so that your out of the box self-signed certificates are accepted. However, if you do require strong security then you should try using certificates signed by a known CA. To disable certificate verification just configure the system property “xmpp.server.certificate.verify”, in the admin console, to false. BTW, you can also enable the debug log to collect more information.


– Gato