powered by Jive Software

Issues opening links in win 8

I am wondering if anyone knows of a work around for this. At my job we have a list of agents that speak spanish so if we recieve a spanish call we place them on hold and use the list to spark the spanish agents and see if they are available to take the call from us. The issue I am running into using win 8.1 and spark 2.7.0 is that when I click the agents spark message link I get a pop-up message saying there are no apps installed on my comnputer that can open an xmpp link and offers to let me search in the windows app store. Has anyone else found a work around for this issue since trying to find each individual person in the different team chats takes way too long and damages my metrics.

Protocoll handlers are stored in the registry. No idea where but you could search for xmpp on Win7, export it and import it as admin in Win8.

Do you mean you have a website with the list of contacts and you press on one of them and get a popup that there is no app for this action? Should it open a chat window with that person? What browser do you use? Can you check the source of this page (Righ click the page and select View Source) and paste here an example how one of these links is constructed?

E.g. i have a html file with such code:

test

When i open it in browser (say IE11 on Win 8.1) it shows a link “test”. When i press it, it launches Spark and openes a chat window. So xmpp uri handler is properly registered on the system. Though there is not much use of it because of the bug SPARK-1446. It openes a chat window with a non-existing “null” person, not with the user “john”.

It should open a chat window to that particular person. the purpose of this page is to allow us to contact spanish speaking agents in order to find someone available to transfer a spanish caller to. However instead of opening a spark chat window I used to get a popup trying to send me to the Windows app store to get an app to open .xmpp links with. I used a reg edit file example I found here to make a reg key that is supposed to make spark open a window when the link is clicked but now it just opens up a new tab in IE with the link and doesnt even ask to go to the app store anymore. For all I know the IT department that builds the webpages for our tools may not have coded the spark chat links correctly, but those people using pidgin rather than spark are not having the same issue, and I only know of for sure one other person who has this issue with spark. the Reg file looks like this

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\xmpp]

@=“URL:XMPP Protocol”

“EditFlags”=dword:00000002

“URL Protocol”=""

[HKEY_CLASSES_ROOT\xmpp\shell]

[HKEY_CLASSES_ROOT\xmpp\shell\open]

[HKEY_CLASSES_ROOT\xmpp\shell\open\command]

@=“C:\Program Files (x86)\Spark\Spark.exe %1”

and the source, well some of it, the parts with the links in it at least, is

user@server

Message was edited by: wroot

I have removed sensitive information from your post. No need to give spam robots addresses, even if they are only xmpp addresses.

First of all the link format in your example is not quite right, though it still works. It should be

xmpp:user@server?message, not just xmpp:user@server

I was able to reproduce your initial issue (a link to a Store) when i have removed xmpp handler from the registry. So it looks like Spark didn’t register uri handler for some reason. And you ahve fixed this by importing the reg file. It did register on my Win 8.1 system and i didn’t have to import anything. Maybe you 2.7.0 build had a bug. I’m using the latest version from here https://igniterealtime.org/downloads/nightly_spark.jsp

I think that you are getting a blank tab because of that “target=”_blank"" in your code example. This part is not needed and you can ask your webpage developers to remove it.

But this won’t help much, because of the Spark bug i have mentioned. It still opens wrong chat window (with a “null” person).

I have tested this with Pidgin and it works fine indeed.

I think i’ve found the reason you didn’t had this registry. The latest Spark installers (starting with 633 build i think) don’t have UAC shield showing on them and they have to be started via Run as administrator. Only this way they can register xmpp uri handler in the registry. SPARK-1590