powered by Jive Software

Issues with email setting in Admin console

Hi,

I have just downloaded and installed the latest version of Openfire on my MacBook and everything works fine except for the email settings in the admin console. I have set them up to my ISPs (and also have tried several others, including Gmail) and each time I try to send a test email it says it has been sent successfully, but never arrives. And if I check the error log I get the following error …

2008.07.30 18:27:44 [org.jivesoftware.util.EmailService$EmailTask.sendMessages(EmailService.java:48 4)]
com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.0 Must issue a STARTTLS command first. b23sm8262698ugd.64

at com.sun.mail.smtp.SMTPTransport.issueSendCommand(SMTPTransport.java:1515)
at com.sun.mail.smtp.SMTPTransport.mailFrom(SMTPTransport.java:1054)
at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:634)
at org.jivesoftware.util.EmailService$EmailTask.sendMessages(EmailService.java:477 )
at org.jivesoftware.util.EmailService.sendMessagesImmediately(EmailService.java:26 4)
at org.jivesoftware.openfire.admin.system_002demailtest_jsp._jspService(system_002 demailtest_jsp.java:139)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)
at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)
at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:66)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:42)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:70)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:99)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:206)
at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
at org.mortbay.jetty.Server.handle(Server.java:324)
at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:843 )
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:648)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

Does anyone else have the same issue? Or any ideas on how to solve it ?

Thanks

-Mic

Hi Mic,

Have you tried selecting the “Use SSL” option on the “Email Settings” page?

Thanks,
Ryan

Hi Ryan,

I have indeed tried that option, but when I do I get the following error when trying to send a test email …

Sending the message failed. Please verify that your host and port settings are correct. (Message: Exception reading response)

Any ideas ?

Thanks,

-Mic

I’m not sure how your regular ISP is set up for email sending… usually it would require SSL/TLS and on port 465 or 587 for outgoing as well as authentication (username/password).

For Gmail setup, the option has to be turned on for the account: http://mail.google.com/support/bin/answer.py?hl=en&answer=13273

The setup docs for various clients can be adapted for Openfire. I’ll give it a try against Gmail tomorrow when I’m back in my office.

You might also have a firewall blocking these ports.

I don’t think the firewall is an issue, but I have just checked the mail app on my iPhone for my Google mail account and it uses both SSL and port 587 so will give this a try when I get home, thanks for the heads-up.

-Mic

Hi Mic,

Hopefully Puffs suggestion will work. If not, I found this http://forums.sun.com/thread.jspa?messageID=3456371 discussion on the Sun Java forums where a couple of potential workarounds were used by different people. Unfortunately most of the workarounds require code changes.

Let us know what you figure out.

Thanks,
Ryan

Hi,

I have tried turning SSL on and changing the port to 587 but it just give the same error …

Sending the message failed. Please verify that your host and port settings are correct. (Message: Exception reading response)

I then enabled debugging of the mail messages, turned on the debug log restarted the server hoping that would give some clues, however the only messages I get in that log are the following …

2008.07.31 16:49:12 JettyLog: EOF

I have read through the forum suggested but I’m not a Java developer so I wouldn’t know where to start changing the code.

Am I the only one experiencing this problem? Does no one else use this setting ?

Thanks

-Mic

Ok so I just did a test using Gmail settings to another email address of mine and it was received succesfully. Note that my Gmail account has POP and IMAP access enabled (from the Gmail doc I posted earlier). Here are my Openfire settings:

SMTP Settings:

Mail Host: smtp.gmail.com

Server Port: 465

Mail Debugging: Off

Server Username: @gmail.com

Server Passwrd:

Use SSL: On

After I click Send Test Email, fill in the info and click send, it gives me a send succesful and a few seconds later I received the test email in my other email account.

1 Like

It is partially correct answer. But port number should be 587 in case of gmail. I got below success message but i am not able to receive mail,

Message was sent successfully. Verify it was sent by checking the mail account you sent the message to.

Please any one can help me on this.

Thanks.

VADIVEL

1 Like