powered by Jive Software

Jappix for Openfire plugin

I really like Jappix. It ia fully functional XMPP web client with a lot of features and even looks like Sparkweb

It has a cool microblog feature like onesocialweb similiar to the one I implemented on a comercial version of SparkWeb using XMPP pubsub. As much as I liked Jappix, I really could not use it. It was developed in PHP and required a second web server with too much fiddly configuration to make Openfire HTTP-BIND run the cross-domain gauntlet. Well that all changed when I discovered*Quercus: *Caucho Technology’s fast, open-source, 100% Java implementation of the PHP language.

It has enabled me to create an Openfire plugin for Jappix that works out-of-the box. No configuration required.

The main reason for my interest in Jappix was the minichat feature which is like the Facebook IM User Interface and is best for integration with other web applications. I have an immediate requirement to put IM into my Clearspace/Openfire setup and Jappix was just right for this.

I am posting this here for community members who might have a need for it. I do not plan on doing any development work on the Jappix PHP code, so if you spot a fault, head over to the Jappix project web site and report it. Please don’t email me.

How to install and use

  1. Download the appropiate zip file for your Openfire server
  2. Stop Openfire
  3. Unzip jappix.war and copy to your plugins folder
  4. Restart Openfire
  5. Go to http://your-server:7070/jappix

References

Download for Openfire-Jappix is http://code.google.com/p/openfire-jappix/downloads/list

Source code is http://code.google.com/p/openfire-jappix/source/checkout

Project Jappix is https://project.jappix.com/

Project Quercus is http://www.caucho.com/resin-3.0/quercus/

2 Likes

In my ubuntu server it worked only if I reloaded plugin

Any plugin that uses the HTTP-BIND web service on default port 7070 has always required a restart of Openfire when installed for the first time. It could be an Openfire fault, but a hot install without a restart does not start the web service.

Understood, thanks.

Would it do also filetransfer to and/or from jabbix to a Spark connected user?

I have two more issue to be reported for Jappix mini with Openfire 3.7. I have used Openfire-Jappix plugin available at http://code.google.com/p/openfire-jappix/downloads/list

  1. I see that Jappix Mini do not come at exact right bottom on IE7 & IE6 however it comes
    fine with Firefox & Chrome. Chat is not fully visible on IE7 ( Windows XP ).
    It appears to me on CSS formatting issue. However I tried some changes but it impacted the
    Firefox formatting of Jappix mini.

  2. I need to know how can I restrict the number of Jappix Mini sesssion per users. I mean based server load, I plan to control how many chat session a user can initiate. Please advice whether it can be done from Openfire or from Jappix mini configuration.

Sorry I case I posting at incorrect thread

You did not read the small print. Please go to the Jappix web site to report Jappix issues. Thank you :slight_smile:

The purpose of this plugin is to use Jappix with Openfire pre-configured. That is why the Jappix admin is disabled. The settings are specific for Openfire BOSH and are hard-coded in two php files (read-main.php and read-hosts.php). The file store/conf/hosts.xml is ignored and is only present because I forgot to delete it. I will remove the offending files in the next release

To rebuild the Jappix plugin, create and run a script file in the plugin root folder that includes this

JAVA_HOME\bin\jar cvf jappix.war .

Watch out for the period (full-stop) at the end

Hi,

how would I use it to make jappix mini widget on my web page?

I have the plugin installed successfully on openfire and it shows jappix page on port 7443

Look at this http://community.igniterealtime.org/blogs/ignite/2011/07/23/jappix-minichat-with -openfire

Hi,

I have openfire 3.7.0 with jappix plugin. my problem is, in the option editor, the save button is dissabled. is this bug or i do something wrong in my config

Please help…

I stop the service

I put the Jappix folder directly into the plugins folder.

C:\Program Files\Openfire\plugins

I have an admin and search folder there…

When start it up again, the folder is removed automatically out of the plugins directory.

In fact, anything i put in there disappears.

i am using openfire 3.7.0

should i be going to the plugs page inside of openfire to upload this?

also http binding is enabled

and script syntax is enabled

is that how it should be?

is there anything i am doing wrong?

HTTP ERROR 404

Problem accessing /jappix. Reason:

Not Found

this is the end result in my web browser

  1. Download the appropiate zip file for your Openfire server
  2. Stop Openfire
  3. Unzip the download zip file and copy jappix.war to your plugins folder
  4. Restart Openfire
  5. Go to http://your-server:7070/jappix

I was unzipping the war file and placing it in the plugins directory. My mistake. thanks for the help.

Will this work with SSL? When I try to use https it gives me the “SSL received a record that exceeded the maximum permissible length” error.

It’s okay, I found it. I forgot about port 7443 for a moment. This is the same SSL certificate that is installed on Openfire, right?

One problem I have found is that search does not work. Is there a way of fixing that? I’ve enabled it in my OpenFire console, but Jappix says the feature is not available.