Java 1.5.0_09/Java 1.6.0-b88

Has anyone tried Wildfire with the beta versions of Java 6? Java 1.5.0_09 isn’'t available for OS X, but there is a beta of 1.6.0 available for OS X via the Developer Connection.


do you have a problem to run Wildfire with JVM 1.5.0_01? I’'m not aware of any new features included in later releases, only bugs got fixed as far as I know.

I don’‘t think that a Java beta is a good base to run Wildfire and I didn’'t try it. This is something developers want to do but not really an option for a production environment.


it2000 wrote:

do you have a problem to run Wildfire with JVM 1.5.0_01?

See here. At least on Linux, you need 1.5.0_09 to get Wildfire to work.

Yup, exact same error on MacOS X which leads me to conclude a newer Java is needed. When I revert to 3.1 all is well.

You could try building Wildfire yourself, maybe it’'s just the compiler that added some incompatibility.


I can’‘t help myself. It seems that I’'m doing something wrong as for me “Wildfire 3.1.1” runs fine with “JVM Version and Vendor: 1.5.0_07 Sun Microsystems Inc. – Java HotSpot™ Server VM”. So I see no need to install 1.5.0_09.

I’'m using the .tar.gz version.


The server worked fine here, too, but the admin plugin (thus the whole web interface) threw that exception on load. Maybe you’'re not using that plugin?

I’'m using the version 1.5.0_06 on Mac OS X 10.4 and Wildfire 3.1.0 works fine.


I did use it to check the Wildfire and the Java version, the text inside the quotes is a 1:1 copy of the admin gui.


3.1.0 works fine, I’‘m talking about 3.1.1 needing Java 1.5.0_09. 1.5.0_07 is the latest version available to OS X, besides the beta Java version. Since you’‘re on OS X, if you upgrade to 3.1.1 let us know if you have a problem. I’'d advise backing up your wildfire directory before you overwrite anything in it with the newer version. That way you can restore it if needed.


I confirm that 3.1.1 works with the JVM 1.5.0 update 06 on Mac OS X.

Date et heure de début de fonctionnement du Serveur : moins d’'une minute – started 16 nov. 2006 10:31:50

Version : Wildfire 3.1.1

Version de la JVM et Fournisseur : 1.5.0_06 Apple Computer, Inc. – Java HotSpot™ Client VM

Serveur d’'Applications : Jetty/5.1.x

OS / Matériel : Mac OS X / ppc

Hey guys,

Different Java 1.5 versions didn’'t change the Java API or its library but only fixed some Java errors and made it faster. That means that Wildfire should be able to run with any Java 1.5 version except if you are hitting a Java 1.5 error which is not highly common. However, we do recommend people to stick to the latest Java 1.5 version so you can run faster and without errors (or less errors). FYI, we are now working on making Wildfire compile under Java 1.6 so stay tuned…


– Gato

Thanks for all the replies folks. I still don’‘t know why 3.1.1 won’'t run on my setup with 1.5.0_6 installed. Anyway, I installed 1.6.0-b88 (beta, I know…) and 3.1.1 runs perfectly with it from what I can see.